View Issue Details

IDProjectCategoryView StatusLast Update
0006695Talerdocumentationpublic2021-08-24 16:23
ReporterFlorian Dold Assigned Tottn  
PriorityhighSeveritytextReproducibilityhave not tried
Status closedResolutionfixed 
Product Versiongit (master) 
Summary0006695: review/edit the LibEuFin How-To
DescriptionThe How-To should be used by GLS to set up LibEuFin on their premises.

Because LibEuFin provides a sandbox implementation of the EBICS protocol, it should be possible to follow all the steps in the How-To even without access to a real EBICS-enabled bank account.
TagsNo tags attached.

Relationships

related to 0006720 resolvedMS libeufin nexus and sandbox should support getting the DB connection string from an environment variable 
parent of 0006729 closedttn Taler Hackathon LibEuFin setup experience 

Activities

ttn

2021-01-21 04:07

developer   ~0017382

I have pushed branch 'dev/ttn/nexus-howto-feedback':

 https://git.taler.net/docs.git/log/?h=dev/ttn/nexus-howto-feedback

Please feel free to accept/reject the feedback as you see fit,
but make sure you address/delete the comment/question
(line that begins with ".. ???").

MS

2021-01-26 19:05

manager   ~0017395

Last edited: 2021-01-26 19:07

TTN: in my opinion you can merge the howto to the master branch. There might be divergences between the code samples and the real CLI because a few sub-commands got recently renamed.

MS

2021-01-26 19:27

manager   ~0017399

Also important: the DB connection string is now available via the environment, therefore the how-to should be adapted to this new style.

ttn

2021-01-27 02:51

developer   ~0017404

OK, i've merged 'dev/ttn/nexus-howto-feedback' into 'master'. Thanks for taking a look.

- Seems like the "Sandbox API" link does not render, even in its current formulation.
  Perhaps that's because it's in a "Note" block. I'll try to move it out and see what happens.

- I'll work in the answer to the question (thanks!) in the next day or so. Generally, our docs
  don't show the result of each invoked command, but i'd like to slowly add that where it
  makes sense and is easy to do. This helps reassure the reader they're on the right track.

- What is the "DB connection string" you mention? Are you talking about env vars like
  'PGHOST' and 'PGDATA', or something else entirely?

MS

2021-01-27 12:24

manager   ~0017407

Last edited: 2021-01-27 12:25

The DB connection string a path to the database. That path is a string in the Java's JDBC format. The following two examples show a SQLite and PostgreSQL path.

1. jdbc:sqlite:/tmp/libeufintestdb
2. jdbc:postgresql://localhost:$port/libeufintestdb?user=$username&password=$password

ttn

2021-01-27 13:24

developer   ~0017411

I understand now. Thanks. When you say "is available in the environment" what does that mean?
Is there a specific variable that has these strings (or one of them) as its value?

MS

2021-01-27 14:08

manager   ~0017413

Exactly. There are two environment variables: LIBEUFIN_NEXUS_DB_CONNECTION and LIBEUFIN_SANDBOX_DB_CONNECTION. Those two variables get read (respectively) by Nexus and Sandbox in order to obtain a DB connection string. And at any given time, each variable is supposed to hold only one connection string.

Does that answer?

ttn

2021-01-29 13:59

developer   ~0017444

Yes, thanks. Last question: When both ways are specified (command-line and env var), which one takes precedence? I imagine command-line, since that's how most programs behave, but i would like your confirmation.

ttn

2021-01-29 15:22

developer   ~0017445

Oops, i see from https://bugs.gnunet.org/view.php?id=6720 that the command-line is no longer supported. Sorry for the noise!

ttn

2021-01-29 19:40

developer   ~0017448

Florian, MS: I think we can close this issue. WDYT?

MS

2021-01-29 21:12

manager   ~0017450

Libeufin changed in the meanwhile: only the Debian packaged version has a default database. The How-To should now say that LIBEUFIN_{SANDBOX,NEXUS}_DB_CONNECTION should be set before trying any operation.

But I'm still not 100% convinced of this solution: what do you/Florian think? Shall LibEuFin provide a default for a database? One reason of the removal was that the user should _know_ where the database is, and not dig through the logs to discover where it is located.

Florian Dold

2021-01-29 21:20

manager   ~0017451

It's fine for me if the DB doesn't have a default.

However, it would be great if the error message you get when you don't specify the database includes an example sqlite db connection string, just to be user friendly.

MS

2021-01-29 22:05

manager   ~0017452

Fixed. I'd say that TTN can now adapt the document (and close this).

ttn

2021-08-10 20:19

developer   ~0018089

MS: Where in the source is the error message that shows the "example sqluite db connection string"?
I'd like to document that explicitly, as a way to make the reader more comfortable should
that happen to them.

(In the meantime, i'll try to install libeufin on gv.taler.net under ~ttn somewhere
and play with "libeufin-sandbox serve" command directly.)

ttn

2021-08-10 20:30

developer   ~0018090

Well, i found it directly. Please ignore the source-code request. (I can grep by myself. :-D)

See commit 474f160fd21e2697f11eebf642952e1807b06577.

Issue History

Date Modified Username Field Change
2021-01-13 23:47 Florian Dold New Issue
2021-01-13 23:47 Florian Dold Status new => assigned
2021-01-13 23:47 Florian Dold Assigned To => ttn
2021-01-21 04:07 ttn Note Added: 0017382
2021-01-26 19:05 MS Note Added: 0017395
2021-01-26 19:06 MS Note Edited: 0017395
2021-01-26 19:07 MS Note Edited: 0017395
2021-01-26 19:27 MS Note Added: 0017399
2021-01-27 02:51 ttn Note Added: 0017404
2021-01-27 12:24 MS Note Added: 0017407
2021-01-27 12:25 MS Note Edited: 0017407
2021-01-27 13:24 ttn Note Added: 0017411
2021-01-27 14:08 MS Note Added: 0017413
2021-01-29 13:59 ttn Note Added: 0017444
2021-01-29 15:22 ttn Note Added: 0017445
2021-01-29 15:23 ttn Relationship added related to 0006720
2021-01-29 19:40 ttn Note Added: 0017448
2021-01-29 21:12 MS Note Added: 0017450
2021-01-29 21:20 Florian Dold Note Added: 0017451
2021-01-29 22:05 MS Note Added: 0017452
2021-01-30 14:57 ttn Relationship added parent of 0006729
2021-01-30 23:55 Christian Grothoff Severity minor => text
2021-06-02 09:57 Christian Grothoff Assigned To ttn => Christian Grothoff
2021-07-13 06:48 Christian Grothoff Assigned To Christian Grothoff => ttn
2021-08-10 20:19 ttn Note Added: 0018089
2021-08-10 20:30 ttn Note Added: 0018090
2021-08-10 20:40 ttn Status assigned => resolved
2021-08-10 20:40 ttn Resolution open => fixed
2021-08-24 16:23 Christian Grothoff Status resolved => closed