View Issue Details

IDProjectCategoryView StatusLast Update
0006676Talerexchangepublic2021-01-06 15:44
ReporterFlorian Dold Assigned ToChristian Grothoff  
PrioritynormalSeveritytextReproducibilityhave not tried
Status resolvedResolutionfixed 
Fixed in Version0.9 
Summary0006676: exchange's crypto client sockets have odd name
DescriptionIt looks like the XXXXXX should be some mktemp pattern, but they are just used as a literal in the file name.

taler-internal@gv:~/taler-runtime/crypto-eddsa-client$ ls
XXXXXX9b2cQn XXXXXXacSqFk XXXXXXEc9Ofm XXXXXXIBe9Fk XXXXXXozgRil XXXXXXWlVpjm XXXXXXYBBzkl
TagsNo tags attached.

Activities

Christian Grothoff

2021-01-06 15:42

manager   ~0017309

Looks like we create twelve "X", and mktemp is defined to only take 6. Likely a case of uselessly putting the XXXXXX twice.

Christian Grothoff

2021-01-06 15:44

manager   ~0017310

And so it was. Fixed in 5d238a6e..1f912112

Issue History

Date Modified Username Field Change
2021-01-06 14:24 Florian Dold New Issue
2021-01-06 14:24 Florian Dold Status new => assigned
2021-01-06 14:24 Florian Dold Assigned To => Christian Grothoff
2021-01-06 15:42 Christian Grothoff Note Added: 0017309
2021-01-06 15:44 Christian Grothoff Note Added: 0017310
2021-01-06 15:44 Christian Grothoff Status assigned => resolved
2021-01-06 15:44 Christian Grothoff Resolution open => fixed
2021-01-06 15:44 Christian Grothoff Fixed in Version => 0.9