View Issue Details

IDProjectCategoryView StatusLast Update
0006647Talerauditorpublic2020-12-26 15:20
ReporterChristian Grothoff Assigned ToChristian Grothoff  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionwon't fix 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product Version0.8.1 
Target Version0.9Fixed in Version0.9 
Summary0006647: auditor unaware of 'failed' bit in prewire table
DescriptionThe bit was recently introduce to handle the MHD_HTTP_NOT_FOUND case in the reply from the bank without stopping all wire transfers overall. However, this right now means that these 'failed' wire transfers will show up as violations in the auditor's report.
We should (!) output them in the auditor's report, but not as 'hard' failures of the exchange, but as issues with the banking system.
TagsNo tags attached.

Activities

Christian Grothoff

2020-12-26 15:20

manager   ~0017238

The auditor actually does not look at the 'prewire' table at all, because the information in it has a wire-specific format and is thus not parseable as such. Which also makes sense, as the auditor will look for the actual wire transfers, not those that are scheduled to maybe happen. So the auditor cannot really interpret that bit. Which is again fine, because first of all it should "never" happen, and second the auditor will already see the missing wire transfer. It doesn't need to really understand "why".

Issue History

Date Modified Username Field Change
2020-11-14 17:57 Christian Grothoff New Issue
2020-11-14 17:57 Christian Grothoff Status new => assigned
2020-11-14 17:57 Christian Grothoff Assigned To => Christian Grothoff
2020-12-26 15:20 Christian Grothoff Note Added: 0017238
2020-12-26 15:20 Christian Grothoff Status assigned => closed
2020-12-26 15:20 Christian Grothoff Resolution open => won't fix
2020-12-26 15:20 Christian Grothoff Fixed in Version => 0.9