View Issue Details

IDProjectCategoryView StatusLast Update
0006639Talerwallet (TS core)public2021-08-24 16:23
ReporterFlorian Dold Assigned ToFlorian Dold  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Versiongit (master) 
Target Version0.8Fixed in Version0.8 
Summary0006639: remove harmless but ugly cyclic module dependencies
DescriptionOur module bundler in particular doesn't like them.

Technically the way we're using cyclic dependencies is fine, but we should try to avoid them, due to subtle differences in how they work in ES6 modules (native format) vs commonjs modules (bundled format).
TagsNo tags attached.

Activities

Florian Dold

2021-06-22 12:21

manager   ~0017975

Fixed in 7383b89cabbfdb8

Issue History

Date Modified Username Field Change
2020-11-03 13:47 Florian Dold New Issue
2020-11-03 13:47 Florian Dold Status new => assigned
2020-11-03 13:47 Florian Dold Assigned To => Florian Dold
2021-06-22 12:21 Florian Dold Status assigned => resolved
2021-06-22 12:21 Florian Dold Resolution open => fixed
2021-06-22 12:21 Florian Dold Note Added: 0017975
2021-07-30 13:56 Christian Grothoff Fixed in Version => 0.8
2021-07-30 14:02 Christian Grothoff Target Version 0.8.1 => 0.8
2021-08-24 16:23 Christian Grothoff Status resolved => closed