View Issue Details

IDProjectCategoryView StatusLast Update
0006638Talerbank (demonstrator)public2020-11-16 12:56
ReporterFlorian Dold Assigned ToFlorian Dold  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version0.8 
Target Version0.8.1 
Summary0006638: bank build system issues
DescriptionOn installing taler on a completely fresh system, I've noticed the following issues in the bank:

1. "make install" requires django to be installed at build time. Is this necessary? I'm wondering if we need to do this i18n step for *every* installation. Could this be a separate step that is not automatically executed on every "make install"? If it's really necessary, we should at least check for it and give a nice error message. Right now we get some import error stack trace.

2. The package seems to require "taler-util>=0.8.0", but pip doesn't have this version yet.
TagsNo tags attached.

Activities

MS

2020-11-03 13:35

manager   ~0017089

Last edited: 2020-11-03 13:37

View 2 revisions

Point 1 got addressed here: 915bca1..1a2031b.

The README has also been updated, but in a nutshell: when you want to install the MO files too, you need the two steps:

#1
$ make i18n

#2
$ make install

Christian Grothoff

2020-11-03 19:22

manager   ~0017092

Why would I NOT want to install the .mo files? Usually 'make i18n' is part of make install for standard GNU build systems. I see no good reason to not include 'i18n' as a subtarget of 'install'.

MS

2020-11-03 20:45

manager   ~0017093

Found this: the alternative is to (1) install all the dependencies before the bank package itself -> (2) generate the .mo files -> (3) install only the bank including the fresh .mo files.

(1) can be done with: "pip3 install --editable ."
(3) with: "pip3 install --no-dependencies ."
(2) is the usual "compilemessages" that needs Django.

MS

2020-11-03 21:30

manager   ~0017095

This is done here: 1a2031b..f20afac

MS

2020-11-03 21:45

manager   ~0017096

taler-util 0.8.0 is on PyPI now.

Florian Dold

2020-11-03 21:55

manager   ~0017097

It's rather non-obvious what the --editable does here and why it's needed. Could you document/explain that?

I also don't understand our installation process anymore ... it looks like now

  make install

won't make sure anymore that the run-time dependencies are also installed?

Florian Dold

2020-11-16 12:56

manager   ~0017143

We're using poetry now, which handles dev dependencies well. The pip upload was also fixed by MS.

Issue History

Date Modified Username Field Change
2020-11-03 00:29 Florian Dold New Issue
2020-11-03 00:29 Florian Dold Status new => assigned
2020-11-03 00:29 Florian Dold Assigned To => MS
2020-11-03 01:09 Florian Dold Product Version => 0.8
2020-11-03 01:09 Florian Dold Target Version => 0.8
2020-11-03 13:35 MS Note Added: 0017089
2020-11-03 13:37 MS Note Edited: 0017089 View Revisions
2020-11-03 19:22 Christian Grothoff Note Added: 0017092
2020-11-03 20:45 MS Note Added: 0017093
2020-11-03 21:30 MS Note Added: 0017095
2020-11-03 21:45 MS Note Added: 0017096
2020-11-03 21:46 MS Status assigned => resolved
2020-11-03 21:46 MS Resolution open => fixed
2020-11-03 21:55 Florian Dold Note Added: 0017097
2020-11-03 22:24 Florian Dold Status resolved => assigned
2020-11-06 09:08 Christian Grothoff Target Version 0.8 => 0.8.1
2020-11-16 12:56 Florian Dold Assigned To MS => Florian Dold
2020-11-16 12:56 Florian Dold Status assigned => resolved
2020-11-16 12:56 Florian Dold Note Added: 0017143