View Issue Details

IDProjectCategoryView StatusLast Update
0006617Talermechant backendpublic2020-11-03 00:03
ReporterMS Assigned ToFlorian Dold  
PrioritynormalSeverityblockReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Versiongit (master) 
Target Version0.8 
Summary0006617: Browser's back button on a paid article shows paywall again.
DescriptionAfter having bought an article from the blog shop, the back button brings the browser again on the paywall, instead of showing
the home page of the shop.
Steps To Reproduce1) Buy an article (with the command line wallet) from the blog shop, at the "int" setup.
2) Click the back button
Additional InformationThe error was observed on the "int" setup, but it should be equally reproducible on the "test" setup.
TagsNo tags attached.

Activities

Florian Dold

2020-10-06 13:17

manager   ~0016998

This seems to be because the merchant order status page immediately redirects to the article again via JS.

Maybe a good solution would be to replace the history (via the appropriate JS API) instead of doing a navigation.

Florian Dold

2020-11-03 00:03

manager   ~0017088

This has been fixed previously in the merchant, by doing a replace instead of an append for the history navigation from
  order_status_url -> fulfillment_url
which fixes the issue.

We couldn't test this previously due to a deployment issue on test, but I've now confirmed that this is fixed.

Issue History

Date Modified Username Field Change
2020-10-02 14:53 MS New Issue
2020-10-02 14:53 MS Status new => assigned
2020-10-02 14:53 MS Assigned To => Florian Dold
2020-10-06 13:16 Florian Dold Category other => mechant backend
2020-10-06 13:16 Florian Dold Product Version git (master) => 0.8.1
2020-10-06 13:17 Florian Dold Note Added: 0016998
2020-10-06 17:48 Florian Dold Product Version 0.8.1 => 0.8
2020-10-07 12:55 Christian Grothoff Severity minor => block
2020-10-07 12:55 Christian Grothoff Product Version 0.8 => git (master)
2020-10-07 12:55 Christian Grothoff Target Version => 0.8
2020-11-03 00:03 Florian Dold Status assigned => resolved
2020-11-03 00:03 Florian Dold Resolution open => fixed
2020-11-03 00:03 Florian Dold Note Added: 0017088