View Issue Details

IDProjectCategoryView StatusLast Update
0006605Talermechant backendpublic2020-09-14 09:07
ReporterFlorian Dold Assigned ToChristian Grothoff  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Versiongit (master) 
Target Version0.8Fixed in Version0.8 
Summary0006605: taler-merchant-dbinit -r doesn't work
DescriptionLooks like this somehow first tries to read the current database with the current schema.
Steps To Reproduce$ taler-merchant-dbinit -r
Sep 13 20:49:47-075508 pq-4100070 ERROR PQprepare (`SELECT contract_terms,claim_token,h_post_data FROM merchant_orders WHERE merchant_orders.merchant_serial= (SELECT merchant_serial FROM merchant_instances WHERE merchant_id=$1) AND merchant_orders.order_id=$2' as `lookup_order') failed with error: ERROR: column "h_post_data" does not exist
LINE 1: SELECT contract_terms,claim_token,h_post_data FROM merchant_...
                                          ^

Failed to initialize database plugin.
TagsNo tags attached.

Activities

Christian Grothoff

2020-09-13 23:12

manager   ~0016968

Is this on a fresh DB? Like the wallet, we didn't implement migration from older DBs.

Florian Dold

2020-09-14 07:16

manager   ~0016969

It's on an existing DB, but since taler-merchant-dbinit is being called with the *reset* flag (-r), I would expect it to not care about migrations!

(Otherwise, there's no point in --reset and we should just remove it!)

Christian Grothoff

2020-09-14 09:07

manager   ~0016970

Fixed in b9e87dd..5466b94

Issue History

Date Modified Username Field Change
2020-09-13 20:57 Florian Dold New Issue
2020-09-13 20:57 Florian Dold Status new => assigned
2020-09-13 20:57 Florian Dold Assigned To => Christian Grothoff
2020-09-13 23:12 Christian Grothoff Note Added: 0016968
2020-09-13 23:14 Christian Grothoff Assigned To Christian Grothoff => Florian Dold
2020-09-13 23:14 Christian Grothoff Status assigned => feedback
2020-09-14 07:16 Florian Dold Note Added: 0016969
2020-09-14 09:07 Christian Grothoff Assigned To Florian Dold => Christian Grothoff
2020-09-14 09:07 Christian Grothoff Status feedback => resolved
2020-09-14 09:07 Christian Grothoff Resolution open => fixed
2020-09-14 09:07 Christian Grothoff Fixed in Version => 0.8
2020-09-14 09:07 Christian Grothoff Note Added: 0016970
2020-09-14 09:07 Christian Grothoff Target Version 0.8.1 => 0.8