View Issue Details

IDProjectCategoryView StatusLast Update
0006579Talerotherpublic2020-09-06 21:56
ReporterFlorian Dold Assigned ToChristian Grothoff  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Target Version0.8Fixed in Version0.8 
Summary0006579: merchant puts the same exchange multiple times in the contract terms
DescriptionWhen creating an order via the blog demo merchant, the contract terms contain this:

exchanges: [
    {
      url: 'https://exchange.test.taler.net/',
      master_pub: 'DY95EXAHQ2BKM2WK9YHZHYG1R7PPMMJPY14FNGP662DAKE35AKQG'
    },
    {
      url: 'https://exchange.test.taler.net/',
      master_pub: 'DY95EXAHQ2BKM2WK9YHZHYG1R7PPMMJPY14FNGP662DAKE35AKQG'
    }
  ],
TagsNo tags attached.

Activities

Christian Grothoff

2020-09-06 21:56

manager   ~0016888

That's because the configuration has the exchange TWICE (merchant-exchange-test and merchant-exchange-CURRENCY).
Fixing deployment script in e0f8ec6..eb56fbf

Issue History

Date Modified Username Field Change
2020-09-06 19:20 Florian Dold New Issue
2020-09-06 19:20 Florian Dold Status new => assigned
2020-09-06 19:20 Florian Dold Assigned To => Christian Grothoff
2020-09-06 21:56 Christian Grothoff Note Added: 0016888
2020-09-06 21:56 Christian Grothoff Status assigned => resolved
2020-09-06 21:56 Christian Grothoff Resolution open => fixed
2020-09-06 21:56 Christian Grothoff Fixed in Version => 0.8