View Issue Details

IDProjectCategoryView StatusLast Update
0006561Talerwallet (TS core)public2021-08-24 16:23
ReporterFlorian Dold Assigned ToFlorian Dold  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionduplicate 
Target Version0.8Fixed in Version0.8 
Summary0006561: it's unclear what the wallet should do with an already expired coin w.r.t. balance and transactions list
DescriptionWhat should the wallet do if a coin is already expired? What should be shown in the balances and transaction list?

We need to consider that the expiration might be a false positive if the system time of the wallet is set to something unreasonable, thus we can't take any destructive action.
TagsNo tags attached.

Relationships

duplicate of 0006558 assignedFlorian Dold transaction item for "lost coins due to expiration" needed 

Activities

Christian Grothoff

2020-09-03 17:18

manager   ~0016823

I'd show it in the transaction history as "lost because wallet was offline since XX" using the timestamp of the coin's expiration for the event and XX being the timestamp the wallet was last 'online' before the coin's expiration. The wallet then needs to simply scan for *future* history entries to find coins to "revive".

Florian Dold

2020-09-03 17:28

manager   ~0016825

Okay, that makes sense. I've linked this issue in 0006558, and will now close this one as a duplicate.

Issue History

Date Modified Username Field Change
2020-09-03 15:48 Florian Dold New Issue
2020-09-03 15:48 Florian Dold Status new => assigned
2020-09-03 15:48 Florian Dold Assigned To => Florian Dold
2020-09-03 17:14 Florian Dold Assigned To Florian Dold => Christian Grothoff
2020-09-03 17:14 Florian Dold Status assigned => feedback
2020-09-03 17:18 Christian Grothoff Note Added: 0016823
2020-09-03 17:18 Christian Grothoff Assigned To Christian Grothoff => Florian Dold
2020-09-03 17:18 Christian Grothoff Status feedback => assigned
2020-09-03 17:28 Florian Dold Status assigned => resolved
2020-09-03 17:28 Florian Dold Resolution open => duplicate
2020-09-03 17:28 Florian Dold Note Added: 0016825
2020-09-03 17:28 Florian Dold Relationship added duplicate of 0006558
2020-10-03 14:08 Christian Grothoff Fixed in Version => 0.8
2020-10-03 14:10 Christian Grothoff Target Version => 0.8
2021-08-24 16:23 Christian Grothoff Status resolved => closed