View Issue Details

IDProjectCategoryView StatusLast Update
0006551Talerwallet (TS core)public2020-09-02 09:52
Reportergrote Assigned ToFlorian Dold  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versiongit (master) 
Target Version0.8Fixed in Version0.8 
Summary0006551: Refund transactions show wrong amounts and reduce balance
DescriptionWhen doing three incremental refunds of a 10 TESTKUDOS purchase, all refund transactions always show the updated amount which is strange, because in the end it looks like you got +10 +10 +10, so 30 TESTKUDOS to your balance. Ideally, the amounts are shown in a way that they add up together to the total refunded amount.

Also while receiving the refund, the balance is dropping close to zero which looks very scary like you can see your wallet being drained. We should probably hide this refresh related balance change from the user.
TagsNo tags attached.

Activities

Florian Dold

2020-09-01 16:41

manager   ~0016809

The wallet currently shows only one refund transaction, even if multiple refunds happened. This is certainly a bug in the wallet.

But it also looks like the UI is displaying transactions even though the wallet-core doesn't return them anymoe?

Florian Dold

2020-09-01 16:44

manager   ~0016810

Ah, no, this might actually only be a bug in wallet-core.

I'm updating the integration test ...

Florian Dold

2020-09-01 20:04

manager   ~0016811

These were two separate issues:

* Refund raw/effective amounts swapped. This one is fixed in v0.7.1-dev.24, and the test-refund-incremental integration test has been extended to check the transactions list.
* Amounts "locked up in refresh" were not shown as part of the available balance in parts of the withdrawal process. This *should* be mostly fixed in v0.7.1-dev.24 as well, but 0006554 tracks the status of more test cases for balance changes.

Issue History

Date Modified Username Field Change
2020-09-01 15:41 grote New Issue
2020-09-01 15:41 grote Status new => assigned
2020-09-01 15:41 grote Assigned To => Florian Dold
2020-09-01 16:41 Florian Dold Note Added: 0016809
2020-09-01 16:44 Florian Dold Note Added: 0016810
2020-09-01 20:04 Florian Dold Note Added: 0016811
2020-09-01 20:04 Florian Dold Status assigned => resolved
2020-09-01 20:04 Florian Dold Resolution open => fixed
2020-09-02 09:52 Christian Grothoff Product Version => git (master)
2020-09-02 09:52 Christian Grothoff Fixed in Version => 0.8
2020-09-02 09:52 Christian Grothoff Target Version => 0.8