View Issue Details

IDProjectCategoryView StatusLast Update
0006542Talerwallet (TS core)public2020-10-03 14:10
ReporterFlorian Dold Assigned ToFlorian Dold  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Target Version0.8Fixed in Version0.8 
Summary0006542: exception isn't properly serialized
DescriptionWe sometimes get the following error message:

"unexpected exception (message: The \"chunk\" argument must be of type string or an instance of Buffer or Uint8Array. Received an instance of OperationFailedError"

This means the wallet (somewhere!) doesn't properly serialize errors.
TagsNo tags attached.

Activities

Florian Dold

2020-09-02 09:37

manager   ~0016817

This has been fixed now. It wasn't actually caused by improperly serializing exceptions, but by a log statement throwing an exception.

Issue History

Date Modified Username Field Change
2020-08-28 18:48 Florian Dold New Issue
2020-08-28 18:48 Florian Dold Status new => assigned
2020-08-28 18:48 Florian Dold Assigned To => Florian Dold
2020-09-02 09:37 Florian Dold Status assigned => resolved
2020-09-02 09:37 Florian Dold Resolution open => fixed
2020-09-02 09:37 Florian Dold Note Added: 0016817
2020-10-03 14:08 Christian Grothoff Fixed in Version => 0.8
2020-10-03 14:10 Christian Grothoff Target Version => 0.8