View Issue Details

IDProjectCategoryView StatusLast Update
0006539Talerbank (demonstrator)public2020-08-28 17:49
ReporterMS Assigned ToMS  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Versiongit (master) 
Target Version0.8Fixed in Version0.8 
Summary0006539: Get rid of signed amounts.
DescriptionThe protocol changed so that no signed amounts are allowed anymore in the JSON.

Instead, whether the amount relates to a debit or credit is now usually told by a "credit_or_debit_indicator" field.

The Python bank got one occurrence removed, but a thorough inspection of the code
should still be done, in order to find more occurrences.
TagsNo tags attached.

Activities

Christian Grothoff

2020-08-25 21:08

manager   ~0016773

Assigning to Torsten, as he needs to update the PoS app for sure.

grote

2020-08-26 15:05

developer   ~0016775

The cashier app was the only app using signed amounts and it has been adapted in https://git.taler.net/taler-android.git/commit/?id=c8dbdaf02d200287cc1242f4826a6c9637398640

Christian Grothoff

2020-08-28 17:49

manager   ~0016788

Seems to be there was only one place, which makes sense.

Issue History

Date Modified Username Field Change
2020-08-25 19:54 MS New Issue
2020-08-25 19:54 MS Status new => assigned
2020-08-25 19:54 MS Assigned To => Marcello Stanisci
2020-08-25 21:07 Christian Grothoff Assigned To Marcello Stanisci => grote
2020-08-25 21:08 Christian Grothoff Note Added: 0016773
2020-08-25 21:08 Christian Grothoff Product Version => git (master)
2020-08-25 21:08 Christian Grothoff Target Version => 0.8
2020-08-26 15:05 grote Note Added: 0016775
2020-08-26 15:05 grote Assigned To grote => MS
2020-08-28 17:49 Christian Grothoff Status assigned => resolved
2020-08-28 17:49 Christian Grothoff Resolution open => fixed
2020-08-28 17:49 Christian Grothoff Fixed in Version => 0.8
2020-08-28 17:49 Christian Grothoff Note Added: 0016788