View Issue Details

IDProjectCategoryView StatusLast Update
0006515Talerwallet (Android App)public2020-10-03 14:10
ReporterChristian Grothoff Assigned Togrote  
PriorityurgentSeveritycrashReproducibilityrandom
Status resolvedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product Versiongit (master) 
Target Version0.8Fixed in Version0.8 
Summary0006515: android app crashes (sometimes) after withdrawing CHF
DescriptionWe simply only get the crash notification ("stopped responding"). Unclear when exactly this happens, Torsten Grothoff always gets it on his phone.
TagsNo tags attached.

Activities

Florian Dold

2020-08-24 07:47

manager   ~0016725

This was caused by proguard optimizing away JSON deserializers in the release build. This should be fixed now, but please verify.

Torsten: Please adjust the proguard rules, which are right now basically set to not optimize/minify anything.

grote

2020-08-26 15:03

developer   ~0016774

Jackson has been completely removed as of https://git.taler.net/taler-android.git/commit/?id=39dcd04750eef1581d0bdde394371ef9ca2808b9 and the old proguard rules have been reinstated saving like 0000003:0000002.5MB in APK size.

Issue History

Date Modified Username Field Change
2020-08-23 15:28 Christian Grothoff New Issue
2020-08-23 15:28 Christian Grothoff Status new => assigned
2020-08-23 15:28 Christian Grothoff Assigned To => Florian Dold
2020-08-24 07:47 Florian Dold Status assigned => feedback
2020-08-24 07:47 Florian Dold Note Added: 0016725
2020-08-24 16:52 Florian Dold Assigned To Florian Dold => grote
2020-08-24 16:52 Florian Dold Status feedback => assigned
2020-08-26 15:03 grote Note Added: 0016774
2020-08-26 15:03 grote Status assigned => resolved
2020-08-26 15:03 grote Resolution open => fixed
2020-10-03 14:09 Christian Grothoff Fixed in Version => 0.8
2020-10-03 14:10 Christian Grothoff Target Version => 0.8