View Issue Details

IDProjectCategoryView StatusLast Update
0006513TalerMerchant frontends (Python3)public2020-09-06 12:43
ReporterTorsten Grothoff Assigned ToChristian Grothoff  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformFirefox 79.0 
Product Versiongit (master) 
Target Version0.8Fixed in Version0.8 
Summary0006513: CSS Fails to load due to mime type
DescriptionError: "The stylesheet http://localhost:8080/static/pure.css was not loaded because its MIME type, “text/html”, is not “text/css”."
The mime type is invalid, and not what was expected.
TagsNo tags attached.

Activities

Christian Grothoff

2020-08-22 23:45

manager   ~0016708

Last edited: 2020-08-23 11:02

View 2 revisions

There may be another cause: we were actually not getting a CSS reply on the system in question, but a 404 page in HTML. Not sure why the CSS was not found though, and in the _console_ Flask was only reporting 200 OK status codes :-(.

MS

2020-08-24 15:46

manager   ~0016746

Sorry, can't reproduce it :-(

Christian Grothoff

2020-08-24 16:18

manager   ~0016747

Can't reproduce hardly fixes it. I have seen it on Torsten's system and couldn't fix it there. So this is surely not 'resolved'.

MS

2020-08-25 09:03

manager   ~0016759

Correct, but: I wanted to mark it *structurally* as "can't reproduce",
and apparently Mantis only lets you do this if you turn the issue to "resolved".
Therefore for Mantis "can't reproduce" _can_ coexist with "resolved".

Let me know if there are other ways to mark as "can't reproduce" without "resolving".

Christian Grothoff

2020-08-25 10:07

manager   ~0016760

I don't think there is a good way. In this case, I think the best thing to do is put a bugnote.

Florian Dold

2020-08-25 15:01

manager   ~0016762

Christian/Torsten: Could you use the Firefox dev tools to diagnose the issue? The "Network" tab of the dev tools will include the response body. That would allow us to diagnose the issue further.

(I can't reproduce this issue on my localhost.)

Christian Grothoff

2020-09-06 12:43

manager   ~0016876

Fixed now by setting the path more explicitly in the Flask constructor in Git Master.

Issue History

Date Modified Username Field Change
2020-08-22 23:24 Torsten Grothoff New Issue
2020-08-22 23:25 Christian Grothoff Product Version => git (master)
2020-08-22 23:25 Christian Grothoff Target Version => 0.8
2020-08-22 23:45 Christian Grothoff Note Added: 0016708
2020-08-23 11:02 Christian Grothoff Note Edited: 0016708 View Revisions
2020-08-24 15:46 MS Note Added: 0016746
2020-08-24 15:46 MS Assigned To => MS
2020-08-24 15:46 MS Status new => resolved
2020-08-24 15:46 MS Resolution open => unable to reproduce
2020-08-24 16:18 Christian Grothoff Assigned To MS =>
2020-08-24 16:18 Christian Grothoff Status resolved => confirmed
2020-08-24 16:18 Christian Grothoff Resolution unable to reproduce => open
2020-08-24 16:18 Christian Grothoff Target Version 0.8 =>
2020-08-24 16:18 Christian Grothoff Note Added: 0016747
2020-08-25 09:03 MS Note Added: 0016759
2020-08-25 10:07 Christian Grothoff Note Added: 0016760
2020-08-25 15:01 Florian Dold Note Added: 0016762
2020-08-25 15:02 Florian Dold Assigned To => Florian Dold
2020-08-25 15:02 Florian Dold Status confirmed => feedback
2020-08-25 19:00 Florian Dold Assigned To Florian Dold => Christian Grothoff
2020-09-06 12:43 Christian Grothoff Status feedback => resolved
2020-09-06 12:43 Christian Grothoff Resolution open => fixed
2020-09-06 12:43 Christian Grothoff Fixed in Version => 0.8
2020-09-06 12:43 Christian Grothoff Note Added: 0016876
2020-09-06 12:43 Christian Grothoff Target Version => 0.8