View Issue Details

IDProjectCategoryView StatusLast Update
0006510TalerMerchant frontends (Python3)public2020-08-23 12:05
ReporterTorsten Grothoff Assigned ToChristian Grothoff  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Versiongit (master) 
Target Version0.8Fixed in Version0.8 
Summary0006510: Syntax error when running with Python2.7.15+ installed | Python 2.7.15+ is used instead of 3.6+ when 3.6 or above is instaleld
DescriptionStack:

WARNING:taler.util.talerconfig:no base directory found
Traceback (most recent call last):
  File "/home/tstudios/.local/bin/taler-merchant-demos", line 98, in <module>
  File "/home/tstudios/.local/lib/python3.6/site-packages/click/core.py", line 610, in invoke
    return callback(*args, **kwargs)
  File "/home/tstudios/.local/bin/taler-merchant-demos", line 94, in demos
    handle_serve_http(config_obj, which_shop, port)
  File "/home/tstudios/.local/bin/taler-merchant-demos", line 78, in handle_serve_http
    "--module", "talermerchantdemos.{}:app".format(whichShop))
  File "/usr/lib/python3.6/os.py", line 542, in execlp
    execvp(file, args)
  File "/usr/lib/python3.6/os.py", line 559, in execvp
    _execvpe(file, args)
  File "/usr/lib/python3.6/os.py", line 604, in _execvpe
    raise last_exc.with_traceback(tb)
  File "/usr/lib/python3.6/os.py", line 594, in _execvpe
    exec_func(fullname, *argrest)
FileNotFoundError: [Errno 2] No such file or directory

Error Description:
It should give a proper error (or warning) if running on versions below 3.6 as there's a syntax error for them, and is/are unsupported versions
TagsNo tags attached.

Activities

Christian Grothoff

2020-08-22 23:06

manager   ~0016705

One issue here seems to be that even if the main script is launched with python3, the actual server via uwsgi can still launch under python2!

Christian Grothoff

2020-08-22 23:11

manager   ~0016706

Torsten installed uwsgi via pip (for python2) and not via pip3. Still, the error message is horrible.

Christian Grothoff

2020-08-23 12:05

manager   ~0016709

Should be fixed in c93ad0e..a1f8eb2: better error on uwsgi not found, plus check for Python 3.6 early on.

Issue History

Date Modified Username Field Change
2020-08-22 22:58 Torsten Grothoff New Issue
2020-08-22 22:58 Christian Grothoff Product Version => git (master)
2020-08-22 22:58 Christian Grothoff Target Version => 0.8
2020-08-22 23:06 Christian Grothoff Note Added: 0016705
2020-08-22 23:11 Christian Grothoff Note Added: 0016706
2020-08-23 12:05 Christian Grothoff Assigned To => Christian Grothoff
2020-08-23 12:05 Christian Grothoff Status new => resolved
2020-08-23 12:05 Christian Grothoff Resolution open => fixed
2020-08-23 12:05 Christian Grothoff Fixed in Version => 0.8
2020-08-23 12:05 Christian Grothoff Note Added: 0016709