View Issue Details

IDProjectCategoryView StatusLast Update
0006489Talerexchangepublic2020-11-13 23:26
ReporterFlorian Dold Assigned ToChristian Grothoff  
PrioritylowSeverityminorReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
Product Versiongit (master) 
Target Version0.8Fixed in Version0.8 
Summary0006489: weird log: libmicrohttpd-[...] INFO Failed to send data in request for `/coins/[...]/deposit'
DescriptionI'm not sure what this log line means, and if it's an issue with the merchant or with the exchange.

This log line appears many times in the exchange log of 0006488.
TagsNo tags attached.

Activities

Christian Grothoff

2020-08-18 10:37

manager   ~0016647

This log line is generated if the server when sending the HTTP reply fails on the 'send' syscall. This can imply the client merely disconnected, or even crashed hard. What is strange that this happens consistently after serialization failures. Strange.

Christian Grothoff

2020-11-13 23:25

manager   ~0017129

I've tried to reproduce it, and cannot anymore.

Issue History

Date Modified Username Field Change
2020-08-18 08:59 Florian Dold New Issue
2020-08-18 08:59 Florian Dold Status new => assigned
2020-08-18 08:59 Florian Dold Assigned To => Christian Grothoff
2020-08-18 10:37 Christian Grothoff Note Added: 0016647
2020-08-25 11:19 Christian Grothoff Priority normal => low
2020-11-13 23:25 Christian Grothoff Status assigned => resolved
2020-11-13 23:25 Christian Grothoff Resolution open => unable to reproduce
2020-11-13 23:25 Christian Grothoff Fixed in Version => 0.8
2020-11-13 23:25 Christian Grothoff Note Added: 0017129
2020-11-13 23:26 Christian Grothoff Product Version => git (master)
2020-11-13 23:26 Christian Grothoff Target Version => 0.8