View Issue Details

IDProjectCategoryView StatusLast Update
0006480Talerexchangepublic2020-08-14 14:49
ReporterChristian Grothoff Assigned ToChristian Grothoff  
PrioritynormalSeveritymajorReproducibilityN/A
Status resolvedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product Versiongit (master) 
Target Version0.8Fixed in Version0.8 
Summary0006480: twisted exchange test with pybank fails
DescriptionI see a 404 HTML response, which then fails to parse as HTML from the pybank. Log attached.
TagsNo tags attached.

Activities

Christian Grothoff

2020-08-12 13:20

manager  

test_bank_api_with_pybank_twisted.log (22,254 bytes)   
Aug 12 13:01:16-394419 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/paths.conf'
Aug 12 13:01:16-394504 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/paths.conf'
Aug 12 13:01:16-394534 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/auditor.conf'
Aug 12 13:01:16-394549 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/auditor.conf'
Aug 12 13:01:16-394569 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/merchant.conf'
Aug 12 13:01:16-394587 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/merchant.conf'
Aug 12 13:01:16-394629 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/coins.conf'
Aug 12 13:01:16-394643 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/coins.conf'
Aug 12 13:01:16-394657 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/bank.conf'
Aug 12 13:01:16-394669 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/bank.conf'
Aug 12 13:01:16-394680 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/taler.conf'
Aug 12 13:01:16-394692 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/taler.conf'
Aug 12 13:01:16-394700 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/exchangedb-postgres.conf'
Aug 12 13:01:16-394713 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/exchangedb-postgres.conf'
Aug 12 13:01:16-394723 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/exchangedb.conf'
Aug 12 13:01:16-394737 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/exchangedb.conf'
Aug 12 13:01:16-394760 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/sync.conf'
Aug 12 13:01:16-394773 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/sync.conf'
Aug 12 13:01:16-394798 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/merchantdb-postgres.conf'
Aug 12 13:01:16-394810 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/merchantdb-postgres.conf'
Aug 12 13:01:16-394821 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/exchange.conf'
Aug 12 13:01:16-394834 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/exchange.conf'
Aug 12 13:01:16-394877 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/auditordb-postgres.conf'
Aug 12 13:01:16-394889 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/auditordb-postgres.conf'
Aug 12 13:01:16-394902 util-33502 DEBUG Asked to parse config file `/home/grothoff/research/taler/exchange/src/testing/test_bank_api_pybank_twisted.conf'
Aug 12 13:01:16-394915 util-33502 DEBUG Deserializing contents of file `/home/grothoff/research/taler/exchange/src/testing/test_bank_api_pybank_twisted.conf'
Aug 12 13:01:16-395069 test-bank-api-with-(fake)bank-twisted-33502 INFO twister_url is http://localhost:8888/
Could connect to twister via IPC socket.
No valid hacks specified!
Aug 12 13:01:16-402607 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/paths.conf'
Aug 12 13:01:16-402653 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/paths.conf'
Aug 12 13:01:16-402670 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/auditor.conf'
Aug 12 13:01:16-402681 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/auditor.conf'
Aug 12 13:01:16-402696 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/merchant.conf'
Aug 12 13:01:16-402708 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/merchant.conf'
Aug 12 13:01:16-402750 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/coins.conf'
Aug 12 13:01:16-402762 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/coins.conf'
Aug 12 13:01:16-402772 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/bank.conf'
Aug 12 13:01:16-402781 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/bank.conf'
Aug 12 13:01:16-402790 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/taler.conf'
Aug 12 13:01:16-402798 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/taler.conf'
Aug 12 13:01:16-402805 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/exchangedb-postgres.conf'
Aug 12 13:01:16-402814 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/exchangedb-postgres.conf'
Aug 12 13:01:16-402821 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/exchangedb.conf'
Aug 12 13:01:16-402830 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/exchangedb.conf'
Aug 12 13:01:16-402847 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/sync.conf'
Aug 12 13:01:16-402856 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/sync.conf'
Aug 12 13:01:16-402873 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/merchantdb-postgres.conf'
Aug 12 13:01:16-402882 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/merchantdb-postgres.conf'
Aug 12 13:01:16-402892 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/exchange.conf'
Aug 12 13:01:16-402902 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/exchange.conf'
Aug 12 13:01:16-402944 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/auditordb-postgres.conf'
Aug 12 13:01:16-402960 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/auditordb-postgres.conf'
Aug 12 13:01:16-402978 util-33502 DEBUG Asked to parse config file `/home/grothoff/research/taler/exchange/src/testing/test_bank_api_pybank_twisted.conf'
Aug 12 13:01:16-402997 util-33502 DEBUG Deserializing contents of file `/home/grothoff/research/taler/exchange/src/testing/test_bank_api_pybank_twisted.conf'
Aug 12 13:01:16-942912 test-bank-api-with-(fake)bank-twisted-33502 INFO Using pybank http://localhost:8888/taler-wire-gateway/Exchange/ on port 8081
Aug 12 13:01:16-942975 test-bank-api-with-(fake)bank-twisted-33502 INFO exchange payto: payto://x-taler-bank/localhost/Exchange
Aug 12 13:01:16-942982 test-bank-api-with-(fake)bank-twisted-33502 INFO user42_payto: payto://x-taler-bank/localhost/42
Aug 12 13:01:16-942989 test-bank-api-with-(fake)bank-twisted-33502 INFO user42_payto: payto://x-taler-bank/localhost/43
Aug 12 13:01:16-943097 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/paths.conf'
Aug 12 13:01:16-943135 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/paths.conf'
Aug 12 13:01:16-943169 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/auditor.conf'
Aug 12 13:01:16-943187 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/auditor.conf'
Aug 12 13:01:16-943215 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/merchant.conf'
Aug 12 13:01:16-943234 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/merchant.conf'
Aug 12 13:01:16-943289 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/coins.conf'
Aug 12 13:01:16-943305 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/coins.conf'
Aug 12 13:01:16-943323 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/bank.conf'
Aug 12 13:01:16-943351 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/bank.conf'
Aug 12 13:01:16-943365 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/taler.conf'
Aug 12 13:01:16-943380 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/taler.conf'
Aug 12 13:01:16-943390 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/exchangedb-postgres.conf'
Aug 12 13:01:16-943406 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/exchangedb-postgres.conf'
Aug 12 13:01:16-943420 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/exchangedb.conf'
Aug 12 13:01:16-943436 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/exchangedb.conf'
Aug 12 13:01:16-943472 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/sync.conf'
Aug 12 13:01:16-943502 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/sync.conf'
Aug 12 13:01:16-943538 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/merchantdb-postgres.conf'
Aug 12 13:01:16-943554 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/merchantdb-postgres.conf'
Aug 12 13:01:16-943567 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/exchange.conf'
Aug 12 13:01:16-943584 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/exchange.conf'
Aug 12 13:01:16-943638 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/auditordb-postgres.conf'
Aug 12 13:01:16-943653 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/auditordb-postgres.conf'
Aug 12 13:01:16-943673 util-33502 DEBUG Asked to parse config file `/home/grothoff/research/taler/exchange/src/testing/test_bank_api_pybank_twisted.conf'
Aug 12 13:01:16-943692 util-33502 DEBUG Deserializing contents of file `/home/grothoff/research/taler/exchange/src/testing/test_bank_api_pybank_twisted.conf'
Waiting for `taler-bank-manage' to be ready (via wget -q -t 2 -T 1 http://localhost:8888/taler-wire-gateway/Exchange/ -o /dev/null -O /dev/null)
.Aug 12 13:01:17-949418 twister-33516 ERROR Download curl failed: Couldn't connect to server
Aug 12 13:01:18-950163 twister-33516 ERROR Download curl failed: Couldn't connect to server
.
Aug 12 13:01:24-983489 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/paths.conf'
Aug 12 13:01:24-983551 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/paths.conf'
Aug 12 13:01:24-983578 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/auditor.conf'
Aug 12 13:01:24-983594 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/auditor.conf'
Aug 12 13:01:24-983618 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/merchant.conf'
Aug 12 13:01:24-983636 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/merchant.conf'
Aug 12 13:01:24-983686 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/coins.conf'
Aug 12 13:01:24-983701 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/coins.conf'
Aug 12 13:01:24-983717 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/bank.conf'
Aug 12 13:01:24-983731 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/bank.conf'
Aug 12 13:01:24-983745 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/taler.conf'
Aug 12 13:01:24-983759 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/taler.conf'
Aug 12 13:01:24-983768 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/exchangedb-postgres.conf'
Aug 12 13:01:24-983794 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/exchangedb-postgres.conf'
Aug 12 13:01:24-983807 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/exchangedb.conf'
Aug 12 13:01:24-983821 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/exchangedb.conf'
Aug 12 13:01:24-983848 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/sync.conf'
Aug 12 13:01:24-983862 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/sync.conf'
Aug 12 13:01:24-983893 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/merchantdb-postgres.conf'
Aug 12 13:01:24-983911 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/merchantdb-postgres.conf'
Aug 12 13:01:24-983927 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/exchange.conf'
Aug 12 13:01:24-983948 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/exchange.conf'
Aug 12 13:01:24-984001 util-33502 DEBUG Asked to parse config file `/home/grothoff/share/taler/config.d/auditordb-postgres.conf'
Aug 12 13:01:24-984017 util-33502 DEBUG Deserializing contents of file `/home/grothoff/share/taler/config.d/auditordb-postgres.conf'
Aug 12 13:01:24-984041 util-33502 DEBUG Asked to parse config file `/home/grothoff/research/taler/exchange/src/testing/test_bank_api_pybank_twisted.conf'
Aug 12 13:01:24-984062 util-33502 DEBUG Deserializing contents of file `/home/grothoff/research/taler/exchange/src/testing/test_bank_api_pybank_twisted.conf'
Aug 12 13:01:24-984184 util-scheduler-33502 DEBUG Registering signal handlers
Aug 12 13:01:24-984222 util-scheduler-33502 DEBUG Adding continuation task 0x562c5cd12ba0
Aug 12 13:01:24-984232 util-scheduler-33502 DEBUG select timeout = end of time
Aug 12 13:01:24-984247 util-scheduler-33502 DEBUG Running task 0x562c5cd135a0
Aug 12 13:01:24-984255 util-os-priority-33502 DEBUG Not installing a handler because $GNUNET_OS_CONTROL_PIPE is empty
Aug 12 13:01:24-984266 util-scheduler-33502 DEBUG destroying task 0x562c5cd135a0
Aug 12 13:01:24-984273 util-scheduler-33502 DEBUG scheduler has more tasks ready!
Aug 12 13:01:24-984281 util-scheduler-33502 DEBUG select timeout = Wed Aug 12 13:01:24 2020
Aug 12 13:01:24-984288 util-scheduler-33502 DEBUG Running task 0x562c5cd12ba0
Aug 12 13:01:24-984326 util-scheduler-33502 DEBUG Adding task 0x562c5cd135a0
Aug 12 13:01:24-984334 util-scheduler-33502 DEBUG Adding shutdown task 0x562c5cd1b910
Aug 12 13:01:24-984342 util-scheduler-33502 DEBUG destroying task 0x562c5cd12ba0
Aug 12 13:01:24-984348 util-scheduler-33502 DEBUG Running task 0x562c5cd1b9a0
Aug 12 13:01:24-984733 util-scheduler-33502 DEBUG destroying task 0x562c5cd1b9a0
Aug 12 13:01:24-984772 util-scheduler-33502 DEBUG select timeout = Wed Aug 12 13:06:24 2020
Aug 12 13:01:24-990923 util-scheduler-33502 DEBUG select timeout = Wed Aug 12 13:06:24 2020
Aug 12 13:01:24-990946 util-scheduler-33502 DEBUG Running task 0x562c5cd12ba0
Aug 12 13:01:24-990983 util-scheduler-33502 DEBUG destroying task 0x562c5cd12ba0
Aug 12 13:01:24-990991 util-scheduler-33502 DEBUG Running task 0x562c5cd1b9a0
Aug 12 13:01:24-991006 test-bank-api-with-(fake)bank-twisted-33502 INFO Transfer of KUDOS:3.22 from http://localhost:8888/2/ to payto://x-taler-bank/localhost/42
Aug 12 13:01:24-991278 util-scheduler-33502 DEBUG destroying task 0x562c5cd1b9a0
Aug 12 13:01:24-991292 util-scheduler-33502 DEBUG Running task 0x562c5cd12ba0
Aug 12 13:01:24-991416 util-scheduler-33502 DEBUG Adding task 0x562c5cd22b40
Aug 12 13:01:24-991431 util-scheduler-33502 DEBUG destroying task 0x562c5cd12ba0
Aug 12 13:01:24-991441 util-scheduler-33502 DEBUG select timeout = Wed Aug 12 13:01:24 2020
Aug 12 13:01:24-992160 util-scheduler-33502 DEBUG Running task 0x562c5cd22b40
Aug 12 13:01:24-992358 util-scheduler-33502 DEBUG Adding task 0x562c5cd215c0
Aug 12 13:01:24-992376 util-scheduler-33502 DEBUG destroying task 0x562c5cd22b40
Aug 12 13:01:24-992400 util-scheduler-33502 DEBUG select timeout = Wed Aug 12 13:01:24 2020
Aug 12 13:01:24-992411 util-scheduler-33502 DEBUG Running task 0x562c5cd215c0
Aug 12 13:01:24-992422 util-scheduler-33502 DEBUG Adding task 0x562c5cd0bb70
Aug 12 13:01:24-992430 util-scheduler-33502 DEBUG destroying task 0x562c5cd215c0
Aug 12 13:01:24-992440 util-scheduler-33502 DEBUG select timeout = Wed Aug 12 13:01:25 2020
* Connection 2 seems to be dead!
* Closing connection 2
* Hostname localhost was found in DNS cache
*   Trying ::1:8081...
* TCP_NODELAY set
* connect to ::1 port 8081 failed: Connection refused
*   Trying 127.0.0.1:8081...
* TCP_NODELAY set
* Connected to localhost (127.0.0.1) port 8081 (#3)
> POST /2/transfer HTTP/1.1
Host: localhost:8081
Authorization: Basic RXhjaGFuZ2U6eA==
Accept: */*
Content-Type: application/json
Content-Length: 309

* We are completely uploaded and fine
* Mark bundle as not supporting multiuse
< HTTP/1.1 404 Not Found
< Content-Type: text/html
< X-Frame-Options: DENY
< Content-Length: 5815
< X-Content-Type-Options: nosniff
< Referrer-Policy: same-origin
< 
* Connection #3 to host localhost left intact
Aug 12 13:01:25-008913 util-scheduler-33502 DEBUG Running task 0x562c5cd0bb70
Aug 12 13:01:25-008998 test-bank-api-with-(fake)bank-twisted-33502 DEBUG Downloaded body: <!DOCTYPE html>
<html lang="en">
<head>
  <meta http-equiv="content-type" content="text/html; charset=utf-8">
  <title>Page not found at /2/transfer</title>
  <meta name="robots" content="NONE,NOARCHIVE">
  <style type="text/css">
    html * { padding:0; margin:0; }
    body * { padding:10px 20px; }
    body * * { padding:0; }
    body { font:small sans-serif; background:#eee; color:#000; }
    body>div { border-bottom:1px solid #ddd; }
    h1 { font-weight:normal; margin-bottom:.4em; }
    h1 span { font-size:60%; color:#666; font-weight:normal; }
    table { border:none; border-collapse: collapse; width:100%; }
    td, th { vertical-align:top; padding:2px 3px; }
    th { width:12em; text-align:right; color:#666; padding-right:.5em; }
    #info { background:#f6f6f6; }
    #info ol { margin: 0.5em 4em; }
    #info ol li { font-family: monospace; }
    #summary { background: #ffc; }
    #explanation { background:#eee; border-bottom: 0px none; }
  </style>
</head>
<body>
  <div id="summary">
    <h1>Page not found <span>(404)</span></h1>
    <table class="meta">
      <tr>
        <th>Request Method:</th>
        <td>POST
Aug 12 13:01:25-009018 test-bank-api-with-(fake)bank-twisted-33502 WARNING Did NOT detect response `<!DOCTYPE html>
<html lang="en">
<head>
  <meta http-equiv="content-type" content="text/html; charset=utf-8">
  <title>Page not found at /2/transfer</title>
  <meta name="robots" content="NONE,NOARCHIVE">
  <style type="text/css">
    html * { padding:0; margin:0; }
    body * { padding:10px 20px; }
    body * * { padding:0; }
    body { font:small sans-serif; background:#eee; color:#000; }
    body>div { border-bottom:1px solid #ddd; }
    h1 { font-weight:normal; margin-bottom:.4em; }
    h1 span { font-size:60%; color:#666; font-weight:normal; }
    table { border:none; border-collapse: collapse; width:100%; }
    td, th { vertical-align:top; padding:2px 3px; }
    th { width:12em; text-align:right; color:#666; padding-right:.5em; }
    #info { background:#f6f6f6; }
    #info ol { margin: 0.5em 4em; }
    #info ol li { font-family: monospace; }
    #summary { background: #ffc; }
    #explanation { background:#eee; border-bottom: 0px none; }
  </style>
</head>
<body>
  <div id="summary">
    <h1>Page not found <span>(404)</span></h1>
    <table class="meta">
      <tr>
        <th>Request Method:</th>
        <td>POST' as JSON
Aug 12 13:01:25-009037 test-bank-api-with-(fake)bank-twisted-33502 WARNING External protocol violation detected at json.c:618.
Aug 12 13:01:25-009045 test-bank-api-with-(fake)bank-twisted-33502 ERROR Assertion failed at testing_api_cmd_bank_transfer.c:210.
Aug 12 13:01:25-009051 test-bank-api-with-(fake)bank-twisted-33502 ERROR Bank returned HTTP status 404/2
Aug 12 13:01:25-009072 test-bank-api-with-(fake)bank-twisted-33502 ERROR Failed at command `debit-1'
Aug 12 13:01:25-009081 util-scheduler-33502 DEBUG GNUNET_SCHEDULER_shutdown
Aug 12 13:01:25-009089 util-scheduler-33502 DEBUG canceling task 0x562c5cd129c0
Aug 12 13:01:25-009096 util-scheduler-33502 DEBUG destroying task 0x562c5cd129c0
Aug 12 13:01:25-009128 util-scheduler-33502 DEBUG destroying task 0x562c5cd0bb70
Aug 12 13:01:25-009135 util-scheduler-33502 DEBUG Running task 0x562c5cd129c0
Aug 12 13:01:25-009144 util-scheduler-33502 DEBUG Adding task 0x562c5cd215c0
Aug 12 13:01:25-009150 util-scheduler-33502 DEBUG destroying task 0x562c5cd129c0
Aug 12 13:01:25-009156 util-scheduler-33502 DEBUG scheduler has more tasks ready!
Aug 12 13:01:25-009165 util-scheduler-33502 DEBUG select timeout = Wed Aug 12 13:01:25 2020
Aug 12 13:01:25-009173 util-scheduler-33502 DEBUG Running task 0x562c5cd1b910
Aug 12 13:01:25-009179 test-bank-api-with-(fake)bank-twisted-33502 INFO Executing shutdown at `debit-1'
Aug 12 13:01:25-009243 util-scheduler-33502 DEBUG canceling task 0x562c5cd215c0
Aug 12 13:01:25-009254 util-scheduler-33502 DEBUG destroying task 0x562c5cd215c0
Aug 12 13:01:25-009262 util-scheduler-33502 DEBUG canceling task 0x562c5cd135a0
Aug 12 13:01:25-009268 util-scheduler-33502 DEBUG destroying task 0x562c5cd135a0
Aug 12 13:01:25-009274 util-scheduler-33502 DEBUG destroying task 0x562c5cd1b910
Aug 12 13:01:25-009281 util-scheduler-33502 DEBUG GNUNET_SCHEDULER_shutdown
Aug 12 13:01:25-009371 util-os-priority-33502 DEBUG Sending signal 2 to pid: 33516 via system call
Aug 12 13:01:25-010451 util-os-priority-33502 DEBUG Sending signal 9 to pid: 33521 via system call
FAIL test_bank_api_with_pybank_twisted (exit status: 1)

Christian Grothoff

2020-08-14 14:49

manager   ~0016632

Fixed in 645fef07..62a53f83

Issue History

Date Modified Username Field Change
2020-08-12 13:20 Christian Grothoff New Issue
2020-08-12 13:20 Christian Grothoff Status new => assigned
2020-08-12 13:20 Christian Grothoff Assigned To => Christian Grothoff
2020-08-12 13:20 Christian Grothoff File Added: test_bank_api_with_pybank_twisted.log
2020-08-12 13:20 Christian Grothoff Assigned To Christian Grothoff =>
2020-08-12 13:20 Christian Grothoff Status assigned => confirmed
2020-08-14 14:49 Christian Grothoff Assigned To => Christian Grothoff
2020-08-14 14:49 Christian Grothoff Status confirmed => resolved
2020-08-14 14:49 Christian Grothoff Resolution open => fixed
2020-08-14 14:49 Christian Grothoff Note Added: 0016632
2020-08-14 14:49 Christian Grothoff Fixed in Version => 0.8