View Issue Details

IDProjectCategoryView StatusLast Update
0006479Talerexchangepublic2020-08-29 13:48
ReporterChristian Grothoff Assigned ToChristian Grothoff  
PrioritynormalSeveritymajorReproducibilityN/A
Status resolvedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product Versiongit (master) 
Target Version0.8Fixed in Version0.8 
Summary0006479: re-enable auditor integration test
DescriptionCurrently the auditor test is disabled as we need to make sure the webex integration test generates a good DB for the new code.
We should re-enable the test and fix any breakage detected.
TagsNo tags attached.

Activities

Florian Dold

2020-08-14 13:03

manager   ~0016626

The wallet now has re-enabled the integration test functionalty. I've updated the invocation syntax in the auditor test scripts.

Additionally, the "integrationtest" functionality has now a test that covers it in the wallet's integration test suite:

  https://git.taler.net/wallet-core.git/tree/packages/taler-integrationtests/src/test-wallettesting.ts

Florian Dold

2020-08-14 13:30

manager   ~0016627

The integration test now fails in some part that seems to be a problem with the test harness, not the wallet:

"""
Revoking denomination null (to affect coin null)
Argument `revoke' malformed. Expected base32 (Crockford) encoded value.
Generation failed, running only on existing DB
SKIP test-revocation.sh (exit status: 77)
"""

Florian Dold

2020-08-14 13:32

manager   ~0016628

For the later parts (that I can't test yet because of the previous issue): The integration test now modifies the passed in wallet DB, so this might affect the test (i.e. a different temp DB file might have to be passed).

Christian Grothoff

2020-08-14 13:37

manager   ~0016629

Looks like the SELECT which is expected to find out the key to identify the denomination to revoke fails to select any record. Probably because something changed (coin selection) in the integration test.

Florian Dold

2020-08-14 13:47

manager   ~0016630

Looking at the old code, it seems like the "spendAmount" has changed from 4 to 5.

I'll adjust this and see what'll happen. These amounts are not configured in the JSON passed to the runIntegrationTest command and not fixed anymore,

Florian Dold

2020-08-14 13:47

manager   ~0016631

Once the auditor test works again, we should add some additional checks in the wallet's integration test for the functionality to make sure that we notice in directly in the wallet when the coin selection changes unexpectedly.

Christian Grothoff

2020-08-29 13:48

manager   ~0016797

fa27c116..d453c47a re-enables the test.

Issue History

Date Modified Username Field Change
2020-08-12 13:18 Christian Grothoff New Issue
2020-08-12 13:18 Christian Grothoff Status new => assigned
2020-08-12 13:18 Christian Grothoff Assigned To => Christian Grothoff
2020-08-12 13:18 Christian Grothoff Assigned To Christian Grothoff =>
2020-08-12 13:18 Christian Grothoff Status assigned => confirmed
2020-08-14 13:03 Florian Dold Note Added: 0016626
2020-08-14 13:30 Florian Dold Note Added: 0016627
2020-08-14 13:32 Florian Dold Note Added: 0016628
2020-08-14 13:37 Christian Grothoff Note Added: 0016629
2020-08-14 13:47 Florian Dold Note Added: 0016630
2020-08-14 13:47 Florian Dold Note Added: 0016631
2020-08-15 04:36 Thehornet17 Tag Attached: bug
2020-08-15 04:36 Thehornet17 Tag Attached: android
2020-08-15 10:00 Christian Grothoff Tag Detached: android
2020-08-15 10:00 Christian Grothoff Tag Detached: bug
2020-08-28 23:51 Christian Grothoff Assigned To => Christian Grothoff
2020-08-28 23:51 Christian Grothoff Status confirmed => assigned
2020-08-29 13:48 Christian Grothoff Status assigned => resolved
2020-08-29 13:48 Christian Grothoff Resolution open => fixed
2020-08-29 13:48 Christian Grothoff Fixed in Version => 0.8
2020-08-29 13:48 Christian Grothoff Note Added: 0016797