View Issue Details

IDProjectCategoryView StatusLast Update
0006465GNUnetbuild processpublic2020-08-14 12:04
Reporterahasenack Assigned Toschanzen  
PrioritynormalSeveritytrivialReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version20.10
Product VersionGit master 
Target Version0.13.2Fixed in Version0.13.2 
Summary0006465: Fails to build with MySQL8: my_bool is gone
DescriptionSince mysql 8, the my_bool type was removed. See "Compilation Notes" in https://dev.mysql.com/doc/relnotes/mysql/8.0/en/news-8-0-1.html:
"""
Incompatible Change: The my_bool type is no longer used in MySQL source code. Any third-party code that used this type to represent C boolean variables should use the bool or int C type instead.
"""

In Ubuntu we have been carrying this workaround patch:
diff --git a/src/mysql/mysql.c b/src/mysql/mysql.c
index 22804d4..4933c44 100644
--- a/src/mysql/mysql.c
+++ b/src/mysql/mysql.c
@@ -24,6 +24,7 @@
  */
 #include "platform.h"
 #include <mysql/mysql.h>
+typedef bool my_bool;
 #include "gnunet_mysql_lib.h"
 
 /**

But that is just a workaround.
Steps To ReproduceBuild gnunet with mysql8
Tagspatch

Activities

ahasenack

2020-08-07 16:36

reporter   ~0016571

Update on the patch:
--- a/src/include/gnunet_mysql_lib.h
+++ b/src/include/gnunet_mysql_lib.h
@@ -32,6 +32,7 @@

 #include "gnunet_util_lib.h"
 #include <mysql/mysql.h>
+typedef bool my_bool;

 #ifdef __cplusplus
 extern "C"

schanzen

2020-08-11 11:43

manager   ~0016587

Fixed in 05004fd89..286759692

schanzen

2020-08-14 12:04

manager   ~0016606

Closing as resolved since at least 0.13.2

Issue History

Date Modified Username Field Change
2020-08-07 15:57 ahasenack New Issue
2020-08-07 15:57 ahasenack Tag Attached: patch
2020-08-07 16:36 ahasenack Note Added: 0016571
2020-08-11 11:43 schanzen Assigned To => schanzen
2020-08-11 11:43 schanzen Status new => resolved
2020-08-11 11:43 schanzen Resolution open => fixed
2020-08-11 11:43 schanzen Fixed in Version => 0.13.2
2020-08-11 11:43 schanzen Note Added: 0016587
2020-08-11 11:53 schanzen Target Version => 0.13.2
2020-08-14 12:04 schanzen Note Added: 0016606
2020-08-14 12:04 schanzen Status resolved => closed