View Issue Details

IDProjectCategoryView StatusLast Update
0006451Talerotherpublic2020-07-31 16:06
ReporterFlorian DoldAssigned ToFlorian Dold 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0006451: consider strategies for rate limiting requests in exchange and merchant
DescriptionCurrently it is easily possible to DoS the exchange or merchant by just doing certain requests for the same resource in a busy loop. This will result in database conflicts, also killing other transactions.

We need to think about strategies to prevent this.

Note that this doesn't have to be a malicious attack, these scenarios easily happen accidentally (as we witnessed with the PoS).
TagsNo tags attached.

Activities

Florian Dold

2020-07-31 16:05

manager   ~0016536

Looks like I actually misinterpreted what's going on here based on the logs.

Issue History

Date Modified Username Field Change
2020-07-31 15:46 Florian Dold New Issue
2020-07-31 16:05 Florian Dold Note Added: 0016536
2020-07-31 16:05 Florian Dold Target Version 0.8 =>
2020-07-31 16:06 Florian Dold Assigned To => Florian Dold
2020-07-31 16:06 Florian Dold Status new => closed
2020-07-31 16:06 Florian Dold Resolution open => no change required