View Issue Details

IDProjectCategoryView StatusLast Update
0006447TalerMerchant frontends (Python3)public2020-10-20 20:33
ReporterMS Assigned ToMS  
PriorityhighSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Versiongit (master) 
Target Version0.8Fixed in Version0.8 
Summary0006447: i18n for demo sites and PyBank needed.
DescriptionUsing the same technology used for the main Taler site.
TagsNo tags attached.

Activities

Christian Grothoff

2020-09-06 13:53

manager   ~0016886

Torsten's branch has an updated design for this, but the overall deployment structure likely needs a major adjustment...

Christian Grothoff

2020-10-11 20:55

manager   ~0017008

This is done, except for the bank. Marcello, would you have time to look at i18n for the pybank?
Specifically, we need to:
1) add the /<lang>/ prefix to all URLs that are user-facing and pass the selected language to the templating logic
2) redirect / to /$LANG/ where $LANG is to be based on the accept-language header of the user and our available languages
3) integrate pybabel into the build system logic to extract strings from .py and .j2 files
4) migrate the existing .html templates to .j2 templates and add the gettext markers around the text to translate

Marcello, I suspect you would be faster at (1) and (2) than I am because you are more familiar with that part of the code.
If needed, I can do 3+4 reasonably well.

MS

2020-10-19 15:43

manager   ~0017022

That is implemented here: 68914c1ef908e115af6dadbad809251ff82f8f2e, for the Python bank.

MS

2020-10-20 15:28

manager   ~0017023

With this commit: 0649fb37a5dbd75e98b842ede5daf6ddecba8526, seemingly all the strings to translate from the bank got wrapped into the "gettext()" call.

Issue History

Date Modified Username Field Change
2020-07-28 16:45 MS New Issue
2020-09-05 13:50 Christian Grothoff Severity minor => feature
2020-09-06 13:52 Christian Grothoff Assigned To => Christian Grothoff
2020-09-06 13:52 Christian Grothoff Status new => assigned
2020-09-06 13:53 Christian Grothoff Note Added: 0016886
2020-10-11 20:55 Christian Grothoff Note Added: 0017008
2020-10-11 20:55 Christian Grothoff Assigned To Christian Grothoff => MS
2020-10-11 20:56 Christian Grothoff Priority normal => high
2020-10-11 20:56 Christian Grothoff Product Version => git (master)
2020-10-11 20:56 Christian Grothoff Target Version => 0.8.1
2020-10-11 21:02 Christian Grothoff Summary i18n for demo sites needed. => i18n for demo sites and PyBank needed.
2020-10-11 21:17 Christian Grothoff Category other => Merchant frontends (Python3)
2020-10-19 15:43 MS Note Added: 0017022
2020-10-20 15:28 MS Note Added: 0017023
2020-10-20 15:29 MS Status assigned => resolved
2020-10-20 15:29 MS Resolution open => fixed
2020-10-20 20:33 Christian Grothoff Fixed in Version => 0.8
2020-10-20 20:33 Christian Grothoff Target Version 0.8.1 => 0.8