View Issue Details

IDProjectCategoryView StatusLast Update
0006441libmicrohttpdlibmicrohttpd APIpublic2020-09-05 02:00
Reportervmatare Assigned ToChristian Grothoff  
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version0.9.71 
Target Version0.9.72Fixed in Version0.9.72 
Summary0006441: MHD_queue_basic_auth_fail_response should also return MHD_Result
Descriptionmicrohttpd.h in v0.9.71 still has:

_MHD_EXTERN int
MHD_queue_basic_auth_fail_response (struct MHD_Connection *connection,
                                    const char *realm,
                                    struct MHD_Response *response);

which is inconsistent with the use of MHD_Result throughout the rest of the API. The doxy also says "@return #MHD_YES on success, #MHD_NO otherwise", so it looks like a simple oversight to me.
TagsNo tags attached.

Activities

Christian Grothoff

2020-09-05 02:00

manager   ~0016868

Has been fixed in Git.

Issue History

Date Modified Username Field Change
2020-07-24 18:21 vmatare New Issue
2020-09-05 02:00 Christian Grothoff Assigned To => Christian Grothoff
2020-09-05 02:00 Christian Grothoff Status new => resolved
2020-09-05 02:00 Christian Grothoff Resolution open => fixed
2020-09-05 02:00 Christian Grothoff Fixed in Version => 0.9.72
2020-09-05 02:00 Christian Grothoff Note Added: 0016868
2020-09-05 02:00 Christian Grothoff Target Version => 0.9.72