View Issue Details

IDProjectCategoryView StatusLast Update
0006426GNUnetATS servicepublic2020-07-28 08:48
Reporterschanzen Assigned ToChristian Grothoff  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Target Version0.13.1Fixed in Version0.13.1 
Summary0006426: ATS minimum bandwidth requires high WAN quota
DescriptionIn order for tests pass more reliably (as ats often falls back to to GNUNET_CONSTANTS_DEFAULT_BW_IN_OUT for no apparent reason)
I increased this value from 1024 to 1024^2.

This leads to an issue with low WAN quota configurations in ats.conf including the default config of 64 KiB.
This leads to peers not bootstrapping anymore.
Root cause for this unknown as I am not really familiar with that part of the code.

We either need to identify and fix the root cause of the ATS fallback behaviour or bump the default quotas for 0.13.1 in order to mitigate this.
I tested that with 10 MiB IN/OUT quota the peers bootstrap again.
TagsNo tags attached.

Activities

Christian Grothoff

2020-07-08 22:18

manager   ~0016407

As I said, fine to bump the default quotas. Should document that _lowering_ them below those values would break things though...

schanzen

2020-07-09 09:16

manager   ~0016408

Fixed in cb09046e4..5a0df5e18

Issue History

Date Modified Username Field Change
2020-07-08 21:33 schanzen New Issue
2020-07-08 21:33 schanzen Status new => assigned
2020-07-08 21:33 schanzen Assigned To => Christian Grothoff
2020-07-08 21:34 schanzen Description Updated View Revisions
2020-07-08 22:18 Christian Grothoff Note Added: 0016407
2020-07-09 09:16 schanzen Status assigned => resolved
2020-07-09 09:16 schanzen Resolution open => fixed
2020-07-09 09:16 schanzen Fixed in Version => 0.13.1
2020-07-09 09:16 schanzen Note Added: 0016408
2020-07-28 08:48 schanzen Status resolved => closed