View Issue Details

IDProjectCategoryView StatusLast Update
0006424gnunet-gtkotherpublic2020-07-28 08:50
Reporterrexxnor Assigned Toschanzen  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.13.0 
Target Version0.13.1Fixed in Version0.13.1 
Summary0006424: gnunet-namestore-gtk does not allow "." when creating an identity
DescriptionWhen trying to add an identity using gnunet-identity

gnunet-identity -C foo.bar

is valid. It is even displayed in gnunet-namestore-gtk correctly after adding it via gnunet-identity.

When trying to add the identity via gnunet-namestore-gtk

gnunet-identity -C bar.foo

the "New" button next to the "Zone Label" input box is greyed out.

The button works as intended for zone labels that do not contain a "."
Steps To ReproduceTry creating the "foo.bar" zone in gnunet-namestore-gtk
Tagsgnunet-gtk

Activities

schanzen

2020-07-07 20:17

manager   ~0016392

Identities with "." are not allowed. This is a bug in gnunet.

Christian Grothoff

2020-07-07 22:55

manager   ~0016393

We used to have a rule that egos/identities had to conform to DNS labels. Alas, that rule was overthrown sometime in 2019. Likely gnunet-namestore-gtk was not updated to permit the period. Should be easy to fix though.

Christian Grothoff

2020-07-07 23:02

manager   ~0016394

Fixed in e4a72e54..90c246d2

Issue History

Date Modified Username Field Change
2020-07-05 10:17 rexxnor New Issue
2020-07-05 10:17 rexxnor Tag Attached: gnunet-gtk
2020-07-07 20:17 schanzen Note Added: 0016392
2020-07-07 20:17 schanzen Assigned To => schanzen
2020-07-07 20:17 schanzen Status new => assigned
2020-07-07 22:55 Christian Grothoff Note Added: 0016393
2020-07-07 23:00 schanzen Target Version => 0.13.1
2020-07-07 23:02 Christian Grothoff Note Added: 0016394
2020-07-07 23:02 Christian Grothoff Status assigned => resolved
2020-07-07 23:02 Christian Grothoff Resolution open => fixed
2020-07-07 23:02 Christian Grothoff Fixed in Version => 0.13.1
2020-07-07 23:03 Christian Grothoff Product Version => 0.13.0
2020-07-07 23:10 schanzen Project GNUnet => gnunet-gtk
2020-07-28 08:50 schanzen Status resolved => closed