View Issue Details

IDProjectCategoryView StatusLast Update
0006201Talerdeployment and operationspublic2020-07-24 11:56
ReporterbuckE Assigned TobuckE  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Target Version0.8Fixed in Version0.8 
Summary0006201: Please provide e-mail settings for Weblate setup
DescriptionCHRISTIAN: per our chat please provide the values for these settings in an e-mail to me and I will update weblate:

EMAIL_HOST (mail.taler.net? taler.net?)

EMAIL_HOST_PASSWORD

EMAIL_HOST_USER (weblate@taler.net?)

EMAIL_PORT
TagsNo tags attached.

Activities

Christian Grothoff

2020-04-23 11:11

manager   ~0015747

Last edited: 2020-04-23 11:11

View 2 revisions

host: localhost
password: none
user: none (IF you need to configure a sender, use weblate@taler.net).
port: 25

buckE

2020-04-24 08:04

reporter   ~0015773

Hm. This seems incorrect? Re: weblate user can not send e-mail using `mail user@hostname` on the command line. And I imagine that is what would be used by python/django running as the weblate user?

So instead, I think we need to authenticate weblate user through the mail system?

For an example, here is a similar configuration using GMAIL settings: https://stackoverflow.com/questions/31324005/django-1-8-sending-mail-using-gmail-smtp

But maybe I am wrong, in which case please explain how mail can be sent from the command line as weblate user, so I can debug where the problem is.

Christian Grothoff

2020-04-24 12:49

manager   ~0015779

Hmm. I checked, and I _think_ a configuration option for localhost relaying was missing. Now that I've set this, I can do:

# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 gv.taler.net ESMTP Postfix
HELO localhost
250 gv.taler.net
MAIL From: grothoff@taler.net
250 2.1.0 Ok
RCPT To: grothoff@gnunet.org
250 2.1.5 Ok
DATA
354 End data with <CR><LF>.<CR><LF>
hello
.
250 2.0.0 Ok: queued as 4C50131C0276
quit
221 2.0.0 Bye
Connection closed by foreign host.

So it should work now.

buckE

2020-04-27 06:32

reporter   ~0015785

Interesting. I'm not sure that weblate's "localhost" function will work that way but maybe. I assumed it would look for a `mail` function locally, that seems common.

Anyway sending an e-mail to myself using that method from weblate user failed. No errors - just didn't receive the e-mail. Message was "250 2.0.0 Ok: queued as 6F52531C0016" Time: 4:24UTC in case you want to check logs.

buckE

2020-04-27 07:15

reporter   ~0015786

Cancel that request. The e-mail came though eventually.

Christian Grothoff

2020-04-27 11:32

manager   ~0015788

buckE: please set bugs to resolved if you think they are resolved. (One can always re-open if truly needed).

buckE

2020-04-28 11:21

reporter   ~0015792

Confirmed working 28 April. Registration e-mail, and feedback e-mail sent.

Issue History

Date Modified Username Field Change
2020-04-23 06:09 buckE New Issue
2020-04-23 06:09 buckE Status new => assigned
2020-04-23 06:09 buckE Assigned To => Christian Grothoff
2020-04-23 11:11 Christian Grothoff Note Added: 0015747
2020-04-23 11:11 Christian Grothoff Note Edited: 0015747 View Revisions
2020-04-23 11:14 Christian Grothoff Assigned To Christian Grothoff => buckE
2020-04-23 11:14 Christian Grothoff Status assigned => feedback
2020-04-24 08:04 buckE Note Added: 0015773
2020-04-24 12:49 Christian Grothoff Note Added: 0015779
2020-04-24 12:51 Christian Grothoff Status feedback => assigned
2020-04-27 06:32 buckE Note Added: 0015785
2020-04-27 07:15 buckE Note Added: 0015786
2020-04-27 11:32 Christian Grothoff Note Added: 0015788
2020-04-28 11:21 buckE Status assigned => resolved
2020-04-28 11:21 buckE Resolution open => fixed
2020-04-28 11:21 buckE Note Added: 0015792
2020-07-24 11:56 Christian Grothoff Target Version => 0.8
2020-07-24 11:56 Christian Grothoff Fixed in Version => 0.8