View Issue Details

IDProjectCategoryView StatusLast Update
0006132Talerotherpublic2021-08-24 16:23
ReporterFlorian Dold Assigned ToMS  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Target Version0.8Fixed in Version0.8 
Summary0006132: merge shop, donations and survey
DescriptionThese packages contain demo applications for Taler. It is frankly quite frustrating to maintain the same boilerplate files for each of them. There is no reason at all to keep them in separate repositories, they should be merged into one.

Possible name: taler-merchant-demos?
TagsNo tags attached.

Activities

MS

2020-07-22 17:35

manager   ~0016496

taler-merchant-demos.git exists now.

Notice that the usual web-common submodule is not checked anymore because it was last updated 3 years ago!
Instead the common CSS files, for example, are within a top-level folder that gets symlinked whenever a shop site
needs it.

MS

2020-07-22 17:38

manager   ~0016497

Common functions were also moved to a shared module, although an additional review to delete leftovers from the code is still needed.

MS

2020-07-22 17:38

manager   ~0016498

Also important: at this stage, the new repository is NOT installed by the deployment script!

Florian Dold

2020-08-21 18:00

manager   ~0016688

Looks like the merge is done!

Issue History

Date Modified Username Field Change
2020-03-21 16:30 Florian Dold New Issue
2020-07-16 15:19 Christian Grothoff Assigned To => Marcello Stanisci
2020-07-16 15:19 Christian Grothoff Status new => assigned
2020-07-16 15:21 Christian Grothoff Assigned To Marcello Stanisci => MS
2020-07-22 17:35 MS Note Added: 0016496
2020-07-22 17:38 MS Note Added: 0016497
2020-07-22 17:38 MS Note Added: 0016498
2020-08-21 18:00 Florian Dold Status assigned => resolved
2020-08-21 18:00 Florian Dold Resolution open => fixed
2020-08-21 18:00 Florian Dold Note Added: 0016688
2020-10-03 14:09 Christian Grothoff Fixed in Version => 0.8
2020-10-03 14:10 Christian Grothoff Target Version => 0.8
2021-08-24 16:23 Christian Grothoff Status resolved => closed