View Issue Details

IDProjectCategoryView StatusLast Update
0006121Talerwallet (Android App)public2020-10-03 14:10
Reportergrote Assigned Togrote  
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
Target Version0.8Fixed in Version0.8 
Summary0006121: Show product images embedded in Data URLs
Descriptionhttps://developer.mozilla.org/en-US/docs/Web/HTTP/Basics_of_HTTP/Data_URIs

Support mime types
* image/jpeg
* image/png
* image/svg (to be decided)

by default we will only show an image if there is only one product, and then we can just show that centered below the product name and just above the 'cancel/buy' buttons.

If there are multiple products, I'd expect that the user has to first expand to the 'view details' list (to see all the products), and then we can show a little image-icon next to each product (5x Salat [IMG-icon]) and if one clicks on that image icon, we show the image full-screen.

The PoS app should also forward embedded images to the contract termsand the docs should be updated as well for contract terms and PoS product definitions.
TagsNo tags attached.

Activities

grote

2020-03-11 14:08

developer   ~0015445

Implemented without SVG support.

Missing: Length validation. Also, for validation, should we decode the image and check the the detected mime-type matches the given one?

Christian Grothoff

2020-09-05 13:55

manager   ~0016871

Is this not a duplicate of 0004880?

grote

2020-09-24 15:01

developer   ~0016981

Looks like it was a duplicate, but now it is for webext, this one is for Android wallet where it was been implemented.

Issue History

Date Modified Username Field Change
2020-03-10 14:00 grote New Issue
2020-03-10 14:00 grote Status new => assigned
2020-03-10 14:00 grote Assigned To => grote
2020-03-11 14:08 grote Note Added: 0015445
2020-09-05 13:55 Christian Grothoff Severity minor => feature
2020-09-05 13:55 Christian Grothoff Note Added: 0016871
2020-09-24 15:01 grote Status assigned => resolved
2020-09-24 15:01 grote Resolution open => fixed
2020-09-24 15:01 grote Note Added: 0016981
2020-10-03 14:08 Christian Grothoff Fixed in Version => 0.8
2020-10-03 14:10 Christian Grothoff Target Version => 0.8