View Issue Details

IDProjectCategoryView StatusLast Update
0006107Talerdeployment and operationspublic2020-10-03 14:10
ReporterChristian Grothoff Assigned ToMS  
PrioritylowSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product Versiongit (master) 
Target Version0.8Fixed in Version0.8 
Summary0006107: taler-backoffice fails to start in test-deployment
Descriptiontaler-test@gv:~$ taler-deployment-arm -I
Services (excluding stopped services):
(started: 10 / failed: 1 / stopped: 4)
taler-exchange (binary='taler-exchange-httpd', status=started)
taler-backoffice (binary='taler-log-adapter', status=failed, exit_status=255, restart_delay='46 s')
taler-auditor (binary='taler-auditor-httpd', status=started)
taler-demobank (binary='taler-log-adapter', status=started)
taler-donations (binary='taler-log-adapter', status=started)
taler-survey (binary='taler-log-adapter', status=started)
taler-sync (binary='sync-httpd', status=started)
taler-aggregator (binary='taler-exchange-aggregator', status=started)
taler-exchange-wirewatch (binary='taler-exchange-wirewatch', status=started)
taler-blog (binary='taler-log-adapter', status=started)
taler-merchant (binary='taler-merchant-httpd', status=started)
Steps To ReproduceLook at taler-test account.
TagsNo tags attached.

Activities

Christian Grothoff

2020-02-25 12:47

manager   ~0015406

After building ('make install') from hand, it now launches. Still, very strange as the BB should have done the exact same instructions. To be investigated further...

Christian Grothoff

2020-08-22 13:55

manager   ~0016698

We just noticed that after a system reboot the 'demo' site also did not come back online automatically. Maybe related.

Christian Grothoff

2020-08-24 22:36

manager   ~0016756

Marcello: assigning to you, as it may relate to your recent findings about wrong paths?

MS

2020-09-04 15:28

manager   ~0016852

If it was because of the wrong paths, then also *other* services should have been affected (= not started),
but the issue refers only to the backoffice service.

However, the problem is not showing up, as (very) recent (0000003:0000002 hours ago) builds of the test-environment did restart the backoffice service.

Christian Grothoff

2020-09-04 15:46

manager   ~0016853

Well, we want to create a new one based on the statless LibEuFin one. But still that one does need to be launched/configured, right? ;-)

MS

2020-09-04 17:26

reporter   ~0016858

Right, but that one will for sure be _another_ problem (since this one seems gone).

MS

2020-09-08 15:15

reporter   ~0016922

Closing in favor of 0006586, that explains the new design.

Issue History

Date Modified Username Field Change
2020-02-24 17:03 Christian Grothoff New Issue
2020-02-25 12:47 Christian Grothoff Note Added: 0015406
2020-02-25 12:47 Christian Grothoff Assigned To => Christian Grothoff
2020-02-25 12:47 Christian Grothoff Status new => assigned
2020-04-13 21:40 Christian Grothoff Target Version 0.7.1 => 0.8.1
2020-07-10 23:29 Christian Grothoff Target Version 0.8.1 => 0.8
2020-07-24 12:04 Christian Grothoff Target Version 0.8 => 0.8.1
2020-07-24 17:18 Christian Grothoff Priority normal => low
2020-07-24 17:18 Christian Grothoff Target Version 0.8.1 =>
2020-08-22 13:55 Christian Grothoff Note Added: 0016698
2020-08-24 22:36 Christian Grothoff Assigned To Christian Grothoff => Marcello Stanisci
2020-08-24 22:36 Christian Grothoff Note Added: 0016756
2020-09-04 14:36 MS Assigned To Marcello Stanisci => MS
2020-09-04 15:28 MS Note Added: 0016852
2020-09-04 15:28 MS Status assigned => feedback
2020-09-04 15:46 Christian Grothoff Note Added: 0016853
2020-09-04 15:46 Christian Grothoff Status feedback => assigned
2020-09-04 17:26 MS Note Added: 0016858
2020-09-08 15:15 MS Status assigned => resolved
2020-09-08 15:15 MS Resolution open => fixed
2020-09-08 15:15 MS Note Added: 0016922
2020-10-03 14:08 Christian Grothoff Fixed in Version => 0.8
2020-10-03 14:10 Christian Grothoff Target Version => 0.8