View Issue Details

IDProjectCategoryView StatusLast Update
0006070GNUnetutil librarypublic2020-08-14 12:04
ReporterFlorian Dold Assigned ToFlorian Dold  
PriorityhighSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Target Version0.13.0 
Summary0006070: ECDSA private keys should be stored little-endian
DescriptionRight now all other keys are stored little-endian, except ECDSA private keys. For easier interoperability, ECDSA should also store keys in little endian.

This change does not directly affect the wire format, but existing keys stored on disk will be interpreted differently, so it is a breaking change.
TagsNo tags attached.

Activities

Florian Dold

2020-05-06 16:50

developer   ~0015861

Fixed in a0a666fb6..82ac104a1

schanzen

2020-08-14 12:04

manager   ~0016620

Closing as resolved since at least 0.13.2

Issue History

Date Modified Username Field Change
2020-02-03 20:21 Florian Dold New Issue
2020-02-03 20:21 Florian Dold Status new => assigned
2020-02-03 20:21 Florian Dold Assigned To => Florian Dold
2020-02-04 18:52 schanzen Target Version => 0.13.0
2020-05-06 16:50 Florian Dold Status assigned => resolved
2020-05-06 16:50 Florian Dold Resolution open => fixed
2020-05-06 16:50 Florian Dold Note Added: 0015861
2020-06-01 00:49 Adminknox Issue cloned: 0006302
2020-06-01 00:52 Adminknox Issue cloned: 0006339
2020-08-14 12:04 schanzen Note Added: 0016620
2020-08-14 12:04 schanzen Status resolved => closed