View Issue Details

IDProjectCategoryView StatusLast Update
0006066Talerbank API (C)public2020-07-31 18:01
ReporterChristian Grothoff Assigned ToMS  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionreopened 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product Versiongit (master) 
Target Version0.7.1Fixed in Version0.8 
Summary0006066: bank should have an API to ask it for the currency it uses
DescriptionThis will be needed for Apps where the user configures a bank connection via URL, username and password and we then need to use the withdraw APIs with a currency. Right now, the app has to magically know the currency or ask the user, both of which is inconvenient. We likely should keep the API endpoint name generic, as there might be other things (especially protocol version) to include in the future as well.
TagsNo tags attached.

Activities

Christian Grothoff

2020-02-04 21:49

manager   ~0015306

bank API specification was updated.

Christian Grothoff

2020-02-04 22:04

manager   ~0015307

taler_bank_lib.h and the fakebank support /config as of e6d6987e..42bc3174

Christian Grothoff

2020-02-04 22:05

manager   ~0015308

Marcello: could you please implement the new "/config" endpoint in nexus and the Python bank? Specification is already done, you only need to return {"version":"0:0:0","currency":"$CURRENCY"} for now.

MS

2020-07-21 12:17

manager   ~0016492

Implemented.

Python bank: 7b85b8731693216f967668e5444cbc85e1f6d995
Nexus: 71201a801ddc58a06392941f808c3ca5148edeea

Note that Nexus does not read configuration values from any files yet,
therefore the currency is hard-coded to "EUR".

grote

2020-07-31 14:30

developer   ~0016535

The test bank currently gives this response:

% curl "https://bank.test.taler.net/config"
{"version": "0.0.0", "currency": "TESTKUDOS"}

which fails parsing, because "0.0.0" != "0:0:0"

MS

2020-07-31 18:01

manager   ~0016537

Fixed here: 32652cc335b140c1e5aaa2f2b13089cc53c3932c

Issue History

Date Modified Username Field Change
2020-01-26 10:35 Christian Grothoff New Issue
2020-01-26 10:35 Christian Grothoff Status new => assigned
2020-01-26 10:35 Christian Grothoff Assigned To => Christian Grothoff
2020-02-04 21:49 Christian Grothoff Note Added: 0015306
2020-02-04 22:04 Christian Grothoff Note Added: 0015307
2020-02-04 22:04 Christian Grothoff Assigned To Christian Grothoff => Marcello Stanisci
2020-02-04 22:05 Christian Grothoff Note Added: 0015308
2020-07-16 15:20 Christian Grothoff Assigned To Marcello Stanisci => MS
2020-07-21 12:17 MS Note Added: 0016492
2020-07-21 12:19 MS Status assigned => resolved
2020-07-21 12:19 MS Resolution open => fixed
2020-07-24 11:56 Christian Grothoff Fixed in Version => 0.8
2020-07-31 14:30 grote Status resolved => feedback
2020-07-31 14:30 grote Resolution fixed => reopened
2020-07-31 14:30 grote Note Added: 0016535
2020-07-31 18:01 MS Note Added: 0016537
2020-07-31 18:01 MS Status feedback => resolved