View Issue Details
|ID||Project||Category||View Status||Date Submitted||Last Update|
|0006065||Taler||exchange||public||2020-01-24 19:49||2020-03-31 16:04|
|Reporter||Florian Dold||Assigned To||Christian Grothoff|
|Priority||normal||Severity||minor||Reproducibility||have not tried|
|Target Version||0.7.0||Fixed in Version||0.7.0|
|Summary||0006065: "hint" and "error" used inconsistently|
|Description||The exchange uses "code" consistently to indicate the error code in a JSON response that represents an error.|
However, sometimes the "error" field is set along with this, and sometimes the "hint" field. They seem to be used completely interchangeably.
I would actually prefer if *all* error messages had the error said to some string, and "hint" would only be present if we had some additional human-readable details.
Alternatively, we would just standardize on *either* "error" or "hint" *and* make this field optional.
I'm leaning slightly towards the first alternative, since having an "error" field *and* a numeric "code" makes it very clear that the JSON represents an error, and it also forces us to always include some human-readable description along with the error code.
|Tags||No tags attached.|
|2020-01-24 19:49||Florian Dold||New Issue|
|2020-01-24 19:49||Florian Dold||Status||new => assigned|
|2020-01-24 19:49||Florian Dold||Assigned To||=> Christian Grothoff|
|2020-02-04 21:03||Christian Grothoff||Status||assigned => resolved|
|2020-02-04 21:03||Christian Grothoff||Resolution||open => fixed|
|2020-02-04 21:03||Christian Grothoff||Fixed in Version||=> 0.7.0|
|2020-02-04 21:03||Christian Grothoff||Note Added: 0015305|
|2020-03-31 16:04||Christian Grothoff||Status||resolved => closed|