View Issue Details

IDProjectCategoryView StatusLast Update
0006065Talerexchangepublic2021-09-02 18:14
ReporterFlorian Dold Assigned ToChristian Grothoff  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Target Version0.7.0Fixed in Version0.7.0 
Summary0006065: "hint" and "error" used inconsistently
DescriptionThe exchange uses "code" consistently to indicate the error code in a JSON response that represents an error.

However, sometimes the "error" field is set along with this, and sometimes the "hint" field. They seem to be used completely interchangeably.

I would actually prefer if *all* error messages had the error said to some string, and "hint" would only be present if we had some additional human-readable details.

Alternatively, we would just standardize on *either* "error" or "hint" *and* make this field optional.

I'm leaning slightly towards the first alternative, since having an "error" field *and* a numeric "code" makes it very clear that the JSON represents an error, and it also forces us to always include some human-readable description along with the error code.
TagsNo tags attached.

Activities

Christian Grothoff

2020-02-04 21:03

manager   ~0015305

Fixed in 9bfeec352b95873bc94b96947a8dd335838f3e8b. docs.git also updated.

Christian Grothoff

2021-09-02 18:14

manager   ~0018271

Fix committed to master branch.

Related Changesets

exchange: master 9bfeec35

2020-02-04 20:57:11

Christian Grothoff

Details Diff
fix 0006065 Affected Issues
0006065
mod - src/exchange/taler-exchange-httpd_mhd.c Diff File
mod - src/exchange/taler-exchange-httpd_refresh_melt.c Diff File
mod - src/exchange/taler-exchange-httpd_refresh_reveal.c Diff File
mod - src/exchange/taler-exchange-httpd_refund.c Diff File
mod - src/exchange/taler-exchange-httpd_reserve_status.c Diff File
mod - src/exchange/taler-exchange-httpd_reserve_withdraw.c Diff File
mod - src/exchange/taler-exchange-httpd_responses.c Diff File
mod - src/include/taler_error_codes.h Diff File

Issue History

Date Modified Username Field Change
2020-01-24 19:49 Florian Dold New Issue
2020-01-24 19:49 Florian Dold Status new => assigned
2020-01-24 19:49 Florian Dold Assigned To => Christian Grothoff
2020-02-04 21:03 Christian Grothoff Status assigned => resolved
2020-02-04 21:03 Christian Grothoff Resolution open => fixed
2020-02-04 21:03 Christian Grothoff Fixed in Version => 0.7.0
2020-02-04 21:03 Christian Grothoff Note Added: 0015305
2020-03-31 16:04 Christian Grothoff Status resolved => closed
2021-09-02 18:13 Christian Grothoff Changeset attached => Taler-exchange master 9bfeec35
2021-09-02 18:14 Christian Grothoff Note Added: 0018271