View Issue Details

IDProjectCategoryView StatusLast Update
0006062Talerotherpublic2020-03-31 16:04
ReporterChristian GrothoffAssigned ToChristian Grothoff 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product Versiongit (master) 
Target Version0.7.0Fixed in Version0.7.0 
Summary0006062: taler-mdb does not terminate if it cannot talk to MDB
DescriptionFor example, if the tty is missconfigured and the write blocks, taler-mdb does not exit because it can never send the 'quit' command to MDB. We should (on shutdown) test if we EVER talked to MDB successfully, and additionally even if we did have a timeout.
TagsNo tags attached.

Activities

Christian Grothoff

2020-01-24 14:27

manager   ~0015298

Should be fixed in Git master, but probably should be tested on the real system once.

Issue History

Date Modified Username Field Change
2020-01-23 08:09 Christian Grothoff New Issue
2020-01-23 08:09 Christian Grothoff Status new => assigned
2020-01-23 08:09 Christian Grothoff Assigned To => Christian Grothoff
2020-01-24 14:27 Christian Grothoff Status assigned => resolved
2020-01-24 14:27 Christian Grothoff Resolution open => fixed
2020-01-24 14:27 Christian Grothoff Fixed in Version => 0.7.0
2020-01-24 14:27 Christian Grothoff Note Added: 0015298
2020-01-24 14:27 Christian Grothoff Target Version => 0.7.0
2020-03-31 16:04 Christian Grothoff Status resolved => closed