View Issue Details

IDProjectCategoryView StatusLast Update
0006039Talerwallet (TS core)public2020-09-05 14:03
ReporterFlorian Dold Assigned ToFlorian Dold  
PrioritynormalSeveritytweakReproducibilityhave not tried
Status assignedResolutionopen 
Product Versiongit (master) 
Summary0006039: consider using underscores for the "public API" exposed by wallet-core
DescriptionTo make naming conventions consistent with other Taler JSON formats, we should consider moving to underscores in the history and pending operations.

Historically the JSON generated by the wallet uses camelCase, since that's the most common convention for writing JavaScript code.

Maybe we can take the route used by GSON (the JSON mapping library for Java (not JavaScript!)) and map to underscores only when (de-)serializing.
TagsNo tags attached.


There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-01-07 21:33 Florian Dold New Issue
2020-01-07 21:33 Florian Dold Assigned To => Florian Dold
2020-01-07 21:33 Florian Dold Status new => assigned
2020-08-20 08:03 Florian Dold Category wallet (JS core) => wallet (TS core)
2020-09-05 14:03 Christian Grothoff Severity minor => tweak
2020-09-05 14:03 Christian Grothoff Product Version => git (master)