View Issue Details

IDProjectCategoryView StatusLast Update
0006017Talerwallet (TS core)public2020-10-03 14:10
ReporterFlorian Dold Assigned ToFlorian Dold  
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionduplicate 
Product Versiongit (master) 
Target Version0.8Fixed in Version0.8 
Summary0006017: wallet should have an API to query currency display information
DescriptionThis will allow UIs to nicely render currencies.

Right now the wallet will just be pre-loaded with a set of currencies.

Later, we might add some way for exchanges (?) or auditors (?) or the user to change/override this.
TagsNo tags attached.

Relationships

duplicate of 0006448 assignedFlorian Dold auditors/exchanges UX; wallet should have better support for regional currencies 
related to 0004819 resolvedFlorian Dold wallet should have a list of common currencies and how to render them 

Activities

Christian Grothoff

2020-03-29 21:55

manager   ~0015473

This is a duplicate.

Florian Dold

2020-09-08 18:00

manager   ~0016930

This is already covered by 6448. For ISO 4217 currency codes in non-regional currencies, the UI should decide how to render it.

Issue History

Date Modified Username Field Change
2019-12-27 17:07 Florian Dold New Issue
2019-12-27 17:07 Florian Dold Status new => assigned
2019-12-27 17:07 Florian Dold Assigned To => Florian Dold
2020-03-29 21:48 Christian Grothoff Target Version 0.7.0 => 0.7.1
2020-03-29 21:55 Christian Grothoff Relationship added duplicate of 0004819
2020-03-29 21:55 Christian Grothoff Note Added: 0015473
2020-03-29 21:56 Christian Grothoff Status assigned => resolved
2020-03-29 21:56 Christian Grothoff Resolution open => duplicate
2020-03-29 21:56 Christian Grothoff Status resolved => confirmed
2020-03-29 21:56 Christian Grothoff Resolution duplicate => open
2020-03-29 21:56 Christian Grothoff Target Version 0.7.1 =>
2020-03-29 21:57 Christian Grothoff Status confirmed => assigned
2020-03-29 21:57 Christian Grothoff Relationship deleted 0004819
2020-03-29 21:57 Christian Grothoff Relationship added related to 0004819
2020-08-20 08:03 Florian Dold Category wallet (JS core) => wallet (TS core)
2020-09-05 13:56 Christian Grothoff Severity minor => feature
2020-09-08 18:00 Florian Dold Status assigned => resolved
2020-09-08 18:00 Florian Dold Resolution open => fixed
2020-09-08 18:00 Florian Dold Note Added: 0016930
2020-09-08 18:00 Florian Dold Relationship added duplicate of 0006448
2020-09-08 18:00 Florian Dold Resolution fixed => duplicate
2020-10-03 14:08 Christian Grothoff Fixed in Version => 0.8
2020-10-03 14:10 Christian Grothoff Target Version => 0.8