View Issue Details

IDProjectCategoryView StatusLast Update
0005995Talerwallet (WebExtensions)public2020-10-03 14:08
Reporterdavidak Assigned ToFlorian Dold  
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version0.5 
Target Version0.7.1Fixed in Version0.8 
Summary0005995: fee sometimes changes in last moment
DescriptionWhen i buy a chapter of the book from RMS, the fee is displayed as 0,09 KUDOS, but sometimes it changes to 0,1 or 0,2 after i accepted the deal. This is a bug!

https://peertube.social/videos/watch/42452d07-a8fc-49d2-97fe-e86929a9c466
TagsNo tags attached.

Activities

Florian Dold

2019-12-19 11:46

manager   ~0015190

Interesting. This is definitely a bug, and the cause might be that before paying, only fees for depositing are shown. But after accepting, full fees including refreshing are shown. I'll investigate further.

Florian Dold

2019-12-19 12:05

manager   ~0015191

Ah, this looks like a different issue. There are many other wallet tabs open, so I am assuming the following happened (which I can even reproduce!):

1. a payment was requested in tab A
2. another payment opened *and* completed in tab B
3. now the payment in tab A needs to be done with a different set of coins, which changes the fees

So the real bug here is that the fees don't get updated when some other payment happens at the same time.

I don't think this is an urgent bug, it's a UI bug in the web extension.

Florian Dold

2020-09-09 09:28

manager   ~0016938

Should be fixed in 0.8.0-rc.1

Issue History

Date Modified Username Field Change
2019-12-19 04:29 davidak New Issue
2019-12-19 10:41 Christian Grothoff Target Version => 0.6
2019-12-19 10:41 Christian Grothoff Priority normal => urgent
2019-12-19 10:41 Christian Grothoff Assigned To => Florian Dold
2019-12-19 10:41 Christian Grothoff Status new => assigned
2019-12-19 11:46 Florian Dold Note Added: 0015190
2019-12-19 12:05 Florian Dold Note Added: 0015191
2019-12-19 12:06 Florian Dold Status assigned => feedback
2019-12-20 19:08 Christian Grothoff Target Version 0.6 => 0.7.0
2019-12-26 22:03 Florian Dold Priority urgent => normal
2019-12-26 22:03 Florian Dold Status feedback => confirmed
2020-03-29 21:49 Christian Grothoff Target Version 0.7.0 => 0.7.1
2020-04-11 18:55 Christian Grothoff Category other => wallet (JS core)
2020-08-20 08:03 Florian Dold Category wallet (JS core) => wallet (TS core)
2020-09-06 11:52 Florian Dold Category wallet (TS core) => wallet (WebExtensions)
2020-09-09 09:28 Florian Dold Status confirmed => resolved
2020-09-09 09:28 Florian Dold Resolution open => fixed
2020-09-09 09:28 Florian Dold Note Added: 0016938
2020-10-03 14:08 Christian Grothoff Fixed in Version => 0.8