View Issue Details

IDProjectCategoryView StatusLast Update
0005966Talerotherpublic2019-11-29 13:02
ReporterChristian GrothoffAssigned ToChristian Grothoff 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionSVN HEAD 
Target Version0.6Fixed in Version0.6 
Summary0005966: code duplication between HTTPDs
DescriptionWe currently have some massive code duplication between the various HTTPDs in the Taler project (merchant, exchange, auditor, sync, anastasis). They all share some parsing and response generation logic, which could likely be unified. The main obstacle seems to be the "-C" flag global variable, but that shouldn't be a deal-breaker either.
TagsNo tags attached.

Activities

Christian Grothoff

2019-11-29 13:02

manager   ~0015097

Fixed with libtalermhd.

Issue History

Date Modified Username Field Change
2019-11-14 22:30 Christian Grothoff New Issue
2019-11-14 22:30 Christian Grothoff Status new => assigned
2019-11-14 22:30 Christian Grothoff Assigned To => Christian Grothoff
2019-11-14 22:30 Christian Grothoff Tag Attached: preblau
2019-11-14 22:33 Christian Grothoff Tag Detached: preblau
2019-11-29 13:02 Christian Grothoff Status assigned => resolved
2019-11-29 13:02 Christian Grothoff Resolution open => fixed
2019-11-29 13:02 Christian Grothoff Fixed in Version => 0.6
2019-11-29 13:02 Christian Grothoff Note Added: 0015097
2019-11-29 13:02 Christian Grothoff Target Version 0.7 => 0.6