View Issue Details

IDProjectCategoryView StatusLast Update
0005878GNUnetbuild processpublic2021-06-10 22:53
Reporternikita Assigned Toschanzen  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Target Version0.15.0Fixed in Version0.15.0 
Summary0005878: underquoted definition warning
Descriptionwhile running bootstrap, I get an underquoted definition warning which probably originated from within our autotools code.

checking for libtoolize / libtool...
/usr/pkg/share/aclocal/libstroke.m4:29: warning: underquoted definition of smr_ARG_WITHLIB
/usr/pkg/share/aclocal/libstroke.m4:29: run info Automake 'Extending aclocal'
/usr/pkg/share/aclocal/libstroke.m4:29: or see https://www.gnu.org/software/automake/manual/automake.html#Extending-aclocal
libtoolize: putting auxiliary files in AC_CONFIG_AUX_DIR, 'build-aux'.
libtoolize: copying file 'build-aux/ltmain.sh'
libtoolize: putting macros in AC_CONFIG_MACRO_DIRS, 'm4'.
libtoolize: copying file 'm4/libtool.m4'
libtoolize: copying file 'm4/ltoptions.m4'
libtoolize: copying file 'm4/ltsugar.m4'
libtoolize: copying file 'm4/ltversion.m4'
libtoolize: copying file 'm4/lt~obsolete.m4'
/usr/pkg/share/aclocal/libstroke.m4:29: warning: underquoted definition of smr_ARG_WITHLIB
/usr/pkg/share/aclocal/libstroke.m4:29: run info Automake 'Extending aclocal'
/usr/pkg/share/aclocal/libstroke.m4:29: or see https://www.gnu.org/software/automake/manual/automake.html#Extending-aclocal
configure.ac:45: installing 'build-aux/compile'
configure.ac:39: installing 'build-aux/missing'
contrib/Makefile.am: installing 'build-aux/depcomp'
/usr/pkg/share/automake-1.16/am/texinfos.am: warning: AM_MAKEINFOHTMLFLAGS was already defined in condition !ACTIVATE_TEXINFO4, which is included in condition TRUE ...
doc/handbook/Makefile.am:21: ... 'AM_MAKEINFOHTMLFLAGS' previously defined here
/usr/pkg/share/automake-1.16/am/texinfos.am: warning: AM_MAKEINFOHTMLFLAGS was already defined in condition !ACTIVATE_TEXINFO4, which is included in condition TRUE ...
doc/tutorial/Makefile.am:19: ... 'AM_MAKEINFOHTMLFLAGS' previously defined here
TagsNo tags attached.

Activities

schanzen

2021-02-28 13:53

manager   ~0017575

Unable to reproduce.

schanzen

2021-05-10 21:58

manager   ~0017813

Was able to reproduce some time ago and changed logic. Should be fixed already, possibly even since 0.14.1.

Issue History

Date Modified Username Field Change
2019-09-06 15:36 nikita New Issue
2019-09-06 15:36 nikita Status new => assigned
2019-09-06 15:36 nikita Assigned To => nikita
2021-02-28 13:34 schanzen Assigned To nikita => schanzen
2021-02-28 13:53 schanzen Status assigned => feedback
2021-02-28 13:53 schanzen Note Added: 0017575
2021-05-10 21:58 schanzen Status feedback => resolved
2021-05-10 21:58 schanzen Resolution open => fixed
2021-05-10 21:58 schanzen Fixed in Version => 0.14.2
2021-05-10 21:58 schanzen Note Added: 0017813
2021-05-10 21:58 schanzen Target Version => 0.14.2
2021-06-10 19:37 schanzen Target Version 0.14.2 => 0.15.0
2021-06-10 22:53 schanzen Fixed in Version 0.14.2 => 0.15.0