View Issue Details

IDProjectCategoryView StatusLast Update
0005868libmicrohttpdotherpublic2019-10-26 19:42
ReporterpombredanneAssigned ToChristian Grothoff 
PrioritynormalSeveritytextReproducibilityN/A
Status closedResolutionfixed 
Product Versioncurrent SVN 
Target Version0.9.67Fixed in Version0.9.67 
Summary0005868: The GPL "with ecos" extension is a modified GPL
DescriptionFWIW, the GPL text included in this GNU project at https://www.gnu.org/software/libmicrohttpd/manual/html_node/GNU-GPL-with-eCos-Extension.html is a modified GPL which is rather uncommon (unless of course approved by the FSF).
The text of the GPL itself cannot be modified in general. The ecos exception should be added outside of the GPL text proper and the GPL text left as-is to comply with the GPL itself.

FYI, libmicrohttpd is the only GNU project that I ever saw modify the GPL text.
TagsNo tags attached.

Activities

Christian Grothoff

2019-09-04 07:02

manager   ~0014850

So what? libmicrohttpd is dual-licensed, also under LGPLv3+. This may be unusual, but not a bug.

Christian Grothoff

2019-09-04 07:03

manager   ~0014851

Oh, and in case you're worried about GPL-compatibility: because MHD is under LGPLv3+, it is automatically also compatible with GPLv3+.

pombredanne

2019-09-04 08:12

reporter   ~0014852

I reported it as a bug because as the GPL states at the very start of its license text:

__ "Everyone is permitted to copy and distribute verbatim copies
of this license document, but changing it is not allowed." __

So my point that it is fine to add the eCos exception text OUTSIDE of the unmodified and pristine GPL text.
But this is NOT OK to modify the GPL text to add INSIDE an extra section 14 with the eCos exception.

eCos does not do this, and there not a single other GNU project that does this: libmicrohttpd is completely unique and IMHO not complying with the GPL.
And the reason nobody does this is is that the GPL license prohibits to change the license text itself.

If you think of it, it kind of make sense, otherwise there would be many copies of the GPL with different terms floating around and that would be rather difficult to handle.

Christian Grothoff

2019-09-04 13:33

manager   ~0014854

Ah, now I understand your point. Fixed in b91e6f71..d44a1870

Issue History

Date Modified Username Field Change
2019-08-31 16:25 pombredanne New Issue
2019-09-04 07:02 Christian Grothoff Note Added: 0014850
2019-09-04 07:02 Christian Grothoff Assigned To => Christian Grothoff
2019-09-04 07:02 Christian Grothoff Severity minor => text
2019-09-04 07:02 Christian Grothoff Reproducibility always => N/A
2019-09-04 07:02 Christian Grothoff Status new => closed
2019-09-04 07:02 Christian Grothoff Resolution open => no change required
2019-09-04 07:03 Christian Grothoff Note Added: 0014851
2019-09-04 08:12 pombredanne Status closed => feedback
2019-09-04 08:12 pombredanne Resolution no change required => reopened
2019-09-04 08:12 pombredanne Note Added: 0014852
2019-09-04 13:33 Christian Grothoff Note Added: 0014854
2019-09-04 13:34 Christian Grothoff Status feedback => resolved
2019-09-04 13:34 Christian Grothoff Resolution reopened => fixed
2019-09-04 13:34 Christian Grothoff Fixed in Version => 0.9.67
2019-09-04 13:34 Christian Grothoff Product Version => current SVN
2019-09-04 13:34 Christian Grothoff Target Version => 0.9.67
2019-10-26 19:42 Christian Grothoff Status resolved => closed