View Issue Details

IDProjectCategoryView StatusLast Update
0005862Talerotherpublic2019-12-20 19:11
ReporterFlorian DoldAssigned ToFlorian Dold 
PrioritynormalSeveritytweakReproducibilityhave not tried
Status closedResolutionfixed 
Product Versiongit (master) 
Target Version0.6Fixed in Version0.6 
Summary0005862: date format is weird and unnecessary
DescriptionParsing and creating it is annoying. There is no real reason for the weird

  stamp_expire: "/Date(123234)/"

shenanigans.

Either we shoud use a number, a string, or some actual JSON wrapper, like

  stamp_expire: { timestamp_sec: 1234 }

which would be easier to parse and generate, and convey the same information with less weirdness.
TagsNo tags attached.

Activities

Christian Grothoff

2019-09-06 02:12

manager   ~0014868

Last edited: 2019-09-16 09:17

View 2 revisions

Hmm. I thought the current "/Date(X)/" had been created based on quite *extensive* discussions between us, with you basically pushing for exactly this format for various JS-related reasons (and other constraints).
Addendum: [1] https://weblogs.asp.net/bleroy/dates-and-json was the original reasoning.

Reasons why we don't just have a number is that it is unclear: is it a time?, also relative time vs. absolute time, and which unit (seconds, nanoseconds, etc.).

Reasons to not use the nested JSON like timestamp_sec include it being even longer, and not really simplifying parsing.

Florian Dold

2019-12-20 02:27

manager   ~0015194

New date format has been implemented (in GNUnet util) and documented (https://docs.taler.net/core/api-common.html#timestamps).

Some test cases in the merchant are still failing because of the change (see 0005997), but closing this one because that's mainly due to the inadequacy of these test cases.

Issue History

Date Modified Username Field Change
2019-08-30 16:08 Florian Dold New Issue
2019-09-04 15:43 Florian Dold Description Updated View Revisions
2019-09-04 15:52 Florian Dold Description Updated View Revisions
2019-09-04 15:56 Florian Dold Description Updated View Revisions
2019-09-06 02:12 Christian Grothoff Note Added: 0014868
2019-09-06 02:12 Christian Grothoff Severity minor => tweak
2019-09-06 02:12 Christian Grothoff Status new => feedback
2019-09-16 09:14 Christian Grothoff Target Version => 0.6
2019-09-16 09:17 Christian Grothoff Note Edited: 0014868 View Revisions
2019-11-14 22:35 Christian Grothoff Target Version 0.6 => 0.7.1
2019-11-29 13:04 Christian Grothoff Product Version 0.6 => git (master)
2019-11-29 13:04 Christian Grothoff Target Version 0.7.1 => 0.6
2019-12-18 23:26 Christian Grothoff Assigned To => Florian Dold
2019-12-18 23:26 Christian Grothoff Status feedback => assigned
2019-12-20 02:27 Florian Dold Status assigned => resolved
2019-12-20 02:27 Florian Dold Resolution open => fixed
2019-12-20 02:27 Florian Dold Note Added: 0015194
2019-12-20 09:47 Christian Grothoff Fixed in Version => 0.6
2019-12-20 19:11 Christian Grothoff Status resolved => closed