View Issue Details

IDProjectCategoryView StatusLast Update
0005817GNUnettransport servicepublic2019-07-24 20:42
ReporterschanzenAssigned Toschanzen 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target Version0.11.6Fixed in Version0.11.6 
Summary0005817: HTTPS transport fails on macOS
DescriptionFound this in logs:

Jul 23 14:06:07-975914 transport-83335 DEBUG Trying to loading TLS certificate from key-file `/var/folders/mq/603h69c166s4szrpmtxmz16rkwr0f0/T//gnunet//test-transport/api-https-p2//https_key_p1.key' cert-file`/var/folders/mq/603h69c166s4szrpmtxmz16rkwr0f0/T//gnunet//test-transport/api-https-p2//https_cert_p1.crt'
Jul 23 14:06:07-975981 transport-83335 DEBUG No usable TLS certificate found, creating certificate
Jul 23 14:06:08-019711 transport-https_server-83335 ERROR No usable TLS certificate found and creating one at `/var/folders/mq/603h69c166s4szrpmtxmz16rkwr0f0/T//gnunet//test-transport/api-https-p2//https_key_p1.key//var/folders/mq/603h69c166s4szrpmtxmz16rkwr0f0/T//gnunet//test-transport/api-https-p2//https_cert_p1.crt' failed!
Jul 23 14:06:08-019729 transport-https_server-83335 ERROR Could not load or create server certificate! Loading plugin failed!
TagsNo tags attached.

Activities

schanzen

2019-07-23 14:14

developer   ~0014725

Apparently, gnunet-transport-certificate-creation.c is doing sth similar to gnunet-gns-proxy-setup-ca. Maybe we should steal that way of creating (reliably) certs with gnutls and/or openssl

schanzen

2019-07-23 14:14

developer   ~0014726

Oh and I forgot to mention: The problem is presumably gnunet-transport-certificate-creation.c. It successfully creates the key files, but does not create the crts (failure, presumably).

schanzen

2019-07-24 00:00

developer   ~0014743

Fixed in ad488bdf1343d85a30d8189884018928b0f699ba

Issue History

Date Modified Username Field Change
2019-07-23 14:09 schanzen New Issue
2019-07-23 14:14 schanzen Note Added: 0014725
2019-07-23 14:14 schanzen Note Added: 0014726
2019-07-24 00:00 schanzen Assigned To => schanzen
2019-07-24 00:00 schanzen Status new => resolved
2019-07-24 00:00 schanzen Resolution open => fixed
2019-07-24 00:00 schanzen Fixed in Version => 0.11.6
2019-07-24 00:00 schanzen Note Added: 0014743
2019-07-24 00:00 schanzen Status resolved => feedback
2019-07-24 00:00 schanzen Resolution fixed => reopened
2019-07-24 00:01 schanzen Status feedback => resolved
2019-07-24 00:01 schanzen Resolution reopened => fixed
2019-07-24 00:01 schanzen Target Version => 0.11.6
2019-07-24 20:42 Christian Grothoff Status resolved => closed