View Issue Details

IDProjectCategoryView StatusLast Update
0005751GNUnetwebpagepublic2019-08-17 02:07
ReporterChristian GrothoffAssigned Toxrs 
PriorityhighSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionSVN HEAD 
Target Version0.11.6Fixed in Version 
Summary0005751: videos not findable/accessible
DescriptionWe need a /videos page .
TagsNo tags attached.

Activities

ng0

2019-07-01 13:00

developer   ~0014633

Either people search on youtube, or our videos are really inaccessible.

One example is that recently someone was searching for more information (without context) and found a talk on youtube.

The videos page, which currently has lots of broken links to archive.org (Question I posed: why archive.org? This is not why we decided to have all of our material in our own infrastructure.), is not satisfactory.

Displaying the videos like images would be good (html5 videos tag).

I'm not sure if at times it could bring more load to the server running the website, but that's yet to be determined.

ng0

2019-07-03 11:36

developer   ~0014636

Last edited: 2019-07-03 11:38

View 2 revisions

This has been partially addressed by linking to the git.

However:

- some links are not recognized/ link to video.html
- we have an extra step, and it is not very clear to the uninitiated that the link leads to the video. Inclusion would probably trigger our cross origin policy. Checking them out directly as part of the build process is not ideal, so if we do this it has to be done serverside (to not drive people like myself away from contributing to the website, my up/down speed is very bad at the moment).
- What about an ">> Watch Video" sort of link?

xrs

2019-07-04 16:04

manager   ~0014638

video.html was improved. See: https://gnunet.org/en/video.html

Is it acceptable now?

ng0

2019-07-04 16:08

developer   ~0014639

The remarks I've made in my previous comment still apply to the version I see on stage.gnunet.org right now.

ng0

2019-07-04 16:20

developer   ~0014640

- some links are not recognized/ link to video.html:
   - for example:
     Martin Schanzenbach, "A Censorship-Resistant and Fully Decentralized Naming System",Technische Universität München

ng0

2019-07-04 16:21

developer   ~0014641

Last edited: 2019-07-04 16:21

View 3 revisions

which happens because of:
        < li >Martin Schanzenbach, <a href="">"A Censorship-Resistant and Fully Decentralized Naming System",</a>Technische Universität München< /li >

ng0

2019-07-04 16:24

developer   ~0014642

For the comment about the ogv files, we might eventually consider converting them into a webm container if ogv is not as well supported as webm. I'm a bit biased because I have the formats all supported here, so I'd have to try some devices of friends.

xrs

2019-07-04 20:18

manager   ~0014643

It seems that those video links I found on archive.org are not as source available since the server crashed.

Apart from searching at youtube.com or media.ccc.de I have no idea how to recover them.

ng0

2019-07-04 20:46

developer   ~0014644

Richard Stallman, "Copyright vs. Community", Technische Universität München -> (almost?) all talks rms gives are standard. since it had nothing to do with gnunet (why is this here anyway?) we can just remove it in my opinion.

Martin Schanzenbach, "A Censorship-Resistant and Fully Decentralized Naming System",Technische Universität München -> https://media.net.in.tum.de/v/Oberseminar-SS12--Design_and_Implementation_of_a_C

We might probably find the rms talk there too, and the rest of the missing TUM talks.

ng0

2019-07-04 20:48

developer   ~0014645

30c3 is easy as well.

Do you want to take on this, or should we split it in half? I do TUM, you do the rest? I haven't looked at how much both of them have missing, but TUM looked like it's close to half of the missing videos.

ng0

2019-07-04 20:51

developer   ~0014646

Last edited: 2019-07-04 20:54

View 2 revisions

And the guix talk was totally unrelated, except for it happening at the same conference I see no reason to keep it. It could be that they still mentioned gnunet in 2015, in which case it would still be related.
newer talks are self-hosted by guix iirc (could be that they have this one as well) and no longer related to gnunet (they seem pretty much settled on ipfs now).

Christian Grothoff

2019-07-04 20:57

manager   ~0014647

I agree, the Guix and Copyright vs. Community talks could be removed from the list.

xrs

2019-07-04 21:49

manager   ~0014648

Ok, made an update on it. Please check again.

ng0

2019-07-05 00:26

developer   ~0014649

Looks good!

Minor confusions, as it was too long ago since I've created those repos based on information back then:

Jeff Burdges, Xolotl - A compact mixnet format with stronger forwared secrecy and hybrid anonymity, GNU Hacker Meeting

this is in 2016.
but I filed it in 2015. Was this just a mistake, or was it 2016 all along?


Rest looks good enough, even though I still think we should have a move action oriented statement ("watch video here") or something like that. It's still clear though.
We could have it like this:

< TITLE > (link to slides slides) - watch video here

since we have a good amount of the slides available.

Jeff Burdges, Xolotl - A compact mixnet format with stronger forwared secrecy and hybrid anonymity, GNU Hacker Meeting (foo) - foo

Like this?

ng0

2019-07-05 00:27

developer   ~0014650

except that mantis strips out the html... gr

ng0

2019-07-05 00:28

developer   ~0014651

Jeff Burdges, Xolotl - A compact mixnet format with stronger forwared secrecy and hybrid anonymity, GNU Hacker Meeting (< link here which then reads just "slides" >) - < link here to the "watch video here" link >

xrs

2019-07-05 19:40

manager   ~0014652

Concerning Jeff Burdges presentation.. if you look the video, it states the year at the beginning. If this is correct then you filed it wrong :-)

I think having the title "Videos" and the colored links is quiet obvious. If you don't mind so much, let's close this issue! :-)

xrs

2019-07-07 21:29

manager   ~0014659

Concerning Jeff Burdges presentation.. if you look the video, it states the year at the beginning. If this is correct then you filed it wrong :-)

I think having the title "Videos" and the colored links is quiet obvious. If you don't mind so much, let's close this issue! :-)

Christian Grothoff

2019-07-07 21:31

manager   ~0014660

Last edited: 2019-07-07 21:32

View 2 revisions

<video width="320" height="240" controls>
  <source src="movie.mp4" type="video/mp4">
  <source src="movie.ogg" type="video/ogg">
Your browser does not support the video tag.
</video>

ng0

2019-07-08 10:53

developer   ~0014662

Additionally adding the src URL below the video as part of some information box, can be done later: Year, Description, Language, Link to Slides, Link to original video, license if any, location, event, speaker.

xrs

2019-07-15 21:46

manager   ~0014688

Added video tag and a javascript snipped. What do you think?

mkv is not supported by HTML5, thus only downloadable.

xrs

2019-07-15 21:49

manager   ~0014689

Oh dear, the content security policy on firefox is enforced. I have to look for another solution. Mhh.

ng0

2019-07-16 00:04

developer   ~0014692

I think we (that is, Christian) could change the policy in this case.

ng0

2019-07-16 00:07

developer   ~0014693

Huh. Okay, js is one way to do it, but maybe my idea would've been too ad-hoc? I was thinking about displaying each video already ready to play (gets loaded later). More copy-pasta.. so maybe your way is better.

xrs

2019-07-16 07:26

manager   ~0014694

Change the CSP is an idea. I need to have a look, how this works and will try some solutions today or tomorrow.

https://content-security-policy.com/

xrs

2019-07-18 17:11

manager   ~0014699

Hey ng0,

to make the javascript work I guess we need the following Header-Info in the Apache config:

Header set Content-Security-Policy "script-src 'self';"

It is almost stated like this in https://content-security-policy.com/ at the bottom.

I'll commit a change in half an hour to have "play" and "download" after the items.

Christian Grothoff

2019-07-18 17:55

manager   ~0014700

GNUnet.org already has that CSP, are we talking about git.gnunet.org or some other server? Please check the headers you get in the browser!

xrs

2019-07-18 18:20

manager   ~0014701

You are right. Maybe what CSP demands is to add the other source domains where the videos are located so that javascript can load those into the video-tag. These are:
- git.gnunet.org
- cdn.media.ccc.de
- audio-video.gnu.org

What about modifying the headers like this?
Header set Content-Security-Policy "script-src 'self'; script-src 'git.gnunet.org'; script-src 'cdn.media.ccc.de'; script-src 'audio-video.gnu.org'"

Christian Grothoff

2019-07-18 19:03

manager   ~0014702

Why are we linking to external resources? Generally, we should never do that as ccc.de has no business seeing visitors to gnunet.org, ditto for gnu.org (even if these are known good-actors, I think the policy of never linking in third-party resources is a good one). So please just move those videos into our own Git.

I'll modify the policy to include git.gnunet.org.

Christian Grothoff

2019-07-18 19:06

manager   ~0014703

Also, looking at this, you seem to have used JavaScript for the video. 0005751:0014660 explains how to do this _without_ JavaScript, which is really what we should do.

xrs

2019-07-19 09:11

reporter   ~0014704

Just for clarification: What is mentionioned in 0005751:0014660 was the basis for this change. But displaying a video for every entry is not the proper UX and implies more loading time. That's why I added JS to use one player and change the source. Another KISS-suggestion?

Plus, we offer a download link, see https://stage.gnunet.org.

Linking to external ressources: Yes, Iwould like to have local ressources, too, but migrating videos is another task.

Christian Grothoff

2019-07-19 10:26

manager   ~0014705

I disagree, having multiple <video> tags doesn't mean the browser will download them all, so it shouldn't really impact loading time beyond the previews, which are comparatively small. If it really gets too big, we should just have a pager, say every 10-50 videos a sub-page ("1 2 3 next"). And sure, a download link should be there, but you can do that with <video> over the controls anyway. No need for a JS player.

As for linking to external resources: migrating the videos clearly _is_ part of this task, as otherwise we'd have to lower our security by setting the CSP to allow third-party.

xrs

2019-07-19 16:50

reporter   ~0014706

Okay, thanks for the hints. I think I have a solution in mind for a proper UX design without JS.

Christian Grothoff

2019-07-23 20:02

manager   ~0014740

xrs: will this happen shortly, or should we remove this one from RC for 0.11.6?

xrs

2019-07-23 22:37

reporter   ~0014742

I'll probable commit a change until tomorrow evening.

xrs

2019-07-24 18:48

reporter   ~0014745

There is a new version. Please help solving the CSP issue.

Concerning video migration: I have no clue how to add a video without cloning the git repo.

Christian Grothoff

2019-07-24 19:36

manager   ~0014746

I've hacked on the CSP now, still odd issues remain. As for video migration, what's wrong with cloning the git repos?

xrs

2019-07-24 19:50

reporter   ~0014747

Thanks!

Cloning the git repos is time and space consuming?

Christian Grothoff

2019-07-24 20:46

manager   ~0014748

You could do it locally: ssh xrs@gnunet.org -- then it should be fast. And once you've added the file(s), you can rm the local copy...

xrs

2019-08-17 02:07

reporter   ~0014783

All mkv videos have been converted to webm. One new video "Big Data, little data, no data" has been added.

Issue History

Date Modified Username Field Change
2019-06-05 11:22 Christian Grothoff New Issue
2019-06-05 18:54 Christian Grothoff Target Version 0.12.0 => 0.11.6
2019-07-01 13:00 ng0 Note Added: 0014633
2019-07-03 11:36 ng0 Note Added: 0014636
2019-07-03 11:38 ng0 Note Edited: 0014636 View Revisions
2019-07-04 16:03 xrs Assigned To => xrs
2019-07-04 16:03 xrs Status new => assigned
2019-07-04 16:04 xrs Status assigned => feedback
2019-07-04 16:04 xrs Note Added: 0014638
2019-07-04 16:08 ng0 Note Added: 0014639
2019-07-04 16:20 ng0 Note Added: 0014640
2019-07-04 16:21 ng0 Note Added: 0014641
2019-07-04 16:21 ng0 Note Edited: 0014641 View Revisions
2019-07-04 16:21 ng0 Note Edited: 0014641 View Revisions
2019-07-04 16:24 ng0 Note Added: 0014642
2019-07-04 20:18 xrs Note Added: 0014643
2019-07-04 20:46 ng0 Note Added: 0014644
2019-07-04 20:48 ng0 Note Added: 0014645
2019-07-04 20:51 ng0 Note Added: 0014646
2019-07-04 20:54 ng0 Note Edited: 0014646 View Revisions
2019-07-04 20:57 Christian Grothoff Note Added: 0014647
2019-07-04 20:57 Christian Grothoff Status feedback => assigned
2019-07-04 21:49 xrs Note Added: 0014648
2019-07-05 00:26 ng0 Note Added: 0014649
2019-07-05 00:27 ng0 Note Added: 0014650
2019-07-05 00:28 ng0 Note Added: 0014651
2019-07-05 19:40 xrs Note Added: 0014652
2019-07-07 21:29 xrs Status assigned => feedback
2019-07-07 21:29 xrs Note Added: 0014659
2019-07-07 21:31 Christian Grothoff Note Added: 0014660
2019-07-07 21:31 Christian Grothoff Status feedback => assigned
2019-07-07 21:32 Christian Grothoff Note Edited: 0014660 View Revisions
2019-07-08 10:53 ng0 Note Added: 0014662
2019-07-15 21:46 xrs Status assigned => feedback
2019-07-15 21:46 xrs Note Added: 0014688
2019-07-15 21:49 xrs Note Added: 0014689
2019-07-16 00:04 ng0 Note Added: 0014692
2019-07-16 00:07 ng0 Note Added: 0014693
2019-07-16 07:26 xrs Note Added: 0014694
2019-07-18 17:11 xrs Note Added: 0014699
2019-07-18 17:55 Christian Grothoff Note Added: 0014700
2019-07-18 17:55 Christian Grothoff Status feedback => assigned
2019-07-18 18:20 xrs Note Added: 0014701
2019-07-18 19:03 Christian Grothoff Note Added: 0014702
2019-07-18 19:06 Christian Grothoff Note Added: 0014703
2019-07-19 09:11 xrs Note Added: 0014704
2019-07-19 10:26 Christian Grothoff Note Added: 0014705
2019-07-19 16:50 xrs Note Added: 0014706
2019-07-23 20:02 Christian Grothoff Note Added: 0014740
2019-07-23 22:37 xrs Note Added: 0014742
2019-07-24 18:48 xrs Note Added: 0014745
2019-07-24 19:36 Christian Grothoff Note Added: 0014746
2019-07-24 19:50 xrs Note Added: 0014747
2019-07-24 20:46 Christian Grothoff Note Added: 0014748
2019-08-17 02:07 xrs Status assigned => resolved
2019-08-17 02:07 xrs Resolution open => fixed
2019-08-17 02:07 xrs Note Added: 0014783