View Issue Details

IDProjectCategoryView StatusLast Update
0005745Talerwallet (WebExtensions)public2019-09-16 09:08
ReporterFlorian DoldAssigned ToFlorian Dold 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.6Fixed in Version0.6 
Summary0005745: wallet should include a "client version cache breaker" in requests to /wire and /keys
DescriptionWhen the wallet is upgraded, it might have stale /keys or /wire information. Similarly, sometimes a deployment might have sent wrong expiration headers, and thus /keys and /wire would live in the cache for too long.

To fix this, the wallet should include a "client version cache breaker" parameter. This allows us to force a re-download of the exchange's information. To preserve privacy, this version number should change as rarely as possible and stay consistent across implementations (browser vs phone etc.).

The request looks like this (cv = client version):

exchange.demo.taler.net/keys?cv=3
TagsNo tags attached.

Activities

Florian Dold

2019-09-06 12:36

manager   ~0014871

Implemented in 4b8b967e58

Issue History

Date Modified Username Field Change
2019-06-03 10:34 Florian Dold New Issue
2019-06-03 10:34 Florian Dold Status new => assigned
2019-06-03 10:34 Florian Dold Assigned To => Florian Dold
2019-09-06 12:36 Florian Dold Status assigned => resolved
2019-09-06 12:36 Florian Dold Resolution open => fixed
2019-09-06 12:36 Florian Dold Note Added: 0014871
2019-09-16 09:08 Christian Grothoff Product Version => SVN HEAD
2019-09-16 09:08 Christian Grothoff Fixed in Version => 0.6
2019-09-16 09:08 Christian Grothoff Target Version => 0.6