View Issue Details

IDProjectCategoryView StatusLast Update
0005716Talerexchangepublic2019-05-09 12:56
ReporterFlorian DoldAssigned ToChristian Grothoff 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version0.5 
Target Version0.6Fixed in Version0.6 
Summary0005716: exchange fails with cryptic error message if DB role is not a superuser
DescriptionThe following error message we get from postgres isn't very intuitive:

ERROR Failed to execute `LOAD 'auto_explain';': access to library "auto_explain" is not allowed/(null)/ERROR: access to library "auto_explain" is not allowed

This happens because only superusers can use the auto explain feature. Maybe we should detect this at run-time and skip this gracefully instead of dying with such a cryptic error message.
TagsNo tags attached.

Activities

Christian Grothoff

2019-05-09 12:56

manager   ~0014383

Fixed in 105555b4..39263a48.

Btw, did you see the comment on AUTO_EXPLAIN:

/**
 * Set to 1 to enable Postgres auto_explain module. This will
 * slow down things a _lot_, but also provide extensive logging
 * in the Postgres database logger for performance analysis.
 */

This was set to "1". Did you turn it off while running the final benchmarks? ;-)

Issue History

Date Modified Username Field Change
2019-05-08 07:13 Florian Dold New Issue
2019-05-08 07:13 Florian Dold Status new => assigned
2019-05-08 07:13 Florian Dold Assigned To => Christian Grothoff
2019-05-09 12:56 Christian Grothoff Status assigned => resolved
2019-05-09 12:56 Christian Grothoff Resolution open => fixed
2019-05-09 12:56 Christian Grothoff Fixed in Version => 0.6
2019-05-09 12:56 Christian Grothoff Note Added: 0014383
2019-05-09 12:56 Christian Grothoff Product Version => 0.5
2019-05-09 12:56 Christian Grothoff Target Version => 0.6
2019-05-09 12:56 Christian Grothoff Additional Information Updated View Revisions