View Issue Details

IDProjectCategoryView StatusLast Update
0005704TalerWeb site(s)public2021-08-24 16:23
ReporterLUG Assigned ToChristian Grothoff  
PrioritynormalSeveritytweakReproducibilityhave not tried
Status closedResolutionfixed 
Product Versiongit (master) 
Target Version0.8Fixed in Version0.8 
Summary0005704: Create common base template
DescriptionTo share the commonalities of all the demo pages (Introduction/Landing, Bank, Essay Shop, Donations, Tipping/Survey) a base template should be included in the web-common repo that all individual templates can inherit from.
TagsNo tags attached.

Activities

LUG

2019-04-26 20:22

developer   ~0014350

Development is happening in the branch feature/common-base-template of the repo web-common.

LUG

2019-04-27 10:22

developer   ~0014354

Development is happening in the branch dev/lukas-grossberger/common-base-template in the relevant frontend repos.

LUG

2019-04-27 15:23

developer   ~0014355

Would someone be so kind to have a look at my modifications to the "Makefile.am" in web-common's dev/lukas-grossberger/common-base-template? I'm completely new to makefiles and think I failed to adjust it to reflect the new directory structure with ccs/ js/ and template/ sub directories, because the hierarchical builds that create and trigger a makefile for web-common fail with errors like for landing:
> make[3]: *** No rule to make target 'taler-wallet-lib.js', needed by 'all-am'. Stop.

Christian Grothoff

2019-05-02 15:21

manager   ~0014375

ng0 was right (on the mailinglist). I've shown you how to do this in 29c609f..c145e27

That said, with this change *all* configure.ac scripts that use the new structure must also be updated. Basically, you'll find at the bottom of the configure.ac a call to AC_OUTPUT([FOO BAR web-common/Makefile]). To that list, we now need to add "web-common/css/Makefile" and "web-common/js/Makefile".

LUG

2019-05-02 22:02

developer   ~0014378

Thanks, Christian. I got it to work together with the matching feature branch in the landing repo. I'll follow that example in the other places as well.

LUG

2019-06-10 14:36

developer   ~0014526

Progress notes:
When trying to port flask powered repos like donations to the common template, "url( ... )" can't be used in templates but instead "url_for('static', filename=' ... ')" has to be used for static files.
Next, try to figure out if "url_for" can be used everywhere, or whether there needs to / can be an alias for "url( ... )" in the jinja context that points to the static equivalent for the flask case.

LUG

2020-01-13 15:27

developer   ~0015263

I'm excited to see Taler progress and regret not having pushed as much as I'd have liked so far.
On my journey to achieve a common base template, a few repos have the common, responsive bootstrap template in the feature branch dev/lukas-grossberger/common-base-template. However, since I couldn't figure out a working local deployment of all Taler components, I wasn't able to update and test all relevant frontend repos to use the common base template.
If someone feels like picking this up from the existing work, I'd be happy to hand it off. I'm not sure when I can put in more time to figure out the local dev setup.

nikita

2020-04-25 15:55

developer   ~0015780

I think I started with this (not necessarily picking up what you had, but I might be wrong), but I'm looking into it again next week.

LUG

2020-04-25 16:59

developer   ~0015782

No worries, I'm happy to hear that the demo frontend gets some additional love. If I can help bounce ideas, let me know.

Christian Grothoff

2020-10-11 21:07

manager   ~0017009

I just merged the landing.git into the taler-merchant-demos.git. This should substantially simply sharing style sheets, etc.

Note that right now the HTML/CSS is still duplicated between the blog/donations/landing/survey sub-pages, but it should now be pretty easy to refactor this to eliminate the duplication.

There is ALSO (some) duplication with the pybank (bank.git), but that uses a different tech stack and is not so easily avoided.

Christian Grothoff

2020-10-12 13:45

manager   ~0017013

Shared style sheets as of 193994e..46dd63a (within taler-merchant-demos, the pybank remains separate).

Issue History

Date Modified Username Field Change
2019-04-26 20:21 LUG New Issue
2019-04-26 20:22 LUG Note Added: 0014350
2019-04-27 10:22 LUG Note Added: 0014354
2019-04-27 15:23 LUG Note Added: 0014355
2019-05-02 15:21 Christian Grothoff Note Added: 0014375
2019-05-02 15:22 Christian Grothoff Assigned To => LUG
2019-05-02 15:22 Christian Grothoff Status new => assigned
2019-05-02 15:22 Christian Grothoff Severity minor => tweak
2019-05-02 15:22 Christian Grothoff Product Version => git (master)
2019-05-02 22:02 LUG Note Added: 0014378
2019-06-10 14:36 LUG Note Added: 0014526
2020-01-13 15:27 LUG Note Added: 0015263
2020-01-14 10:02 Christian Grothoff Assigned To LUG => nikita
2020-04-25 15:55 nikita Note Added: 0015780
2020-04-25 15:56 nikita Status assigned => acknowledged
2020-04-25 16:59 LUG Note Added: 0015782
2020-05-05 09:53 nikita Assigned To nikita =>
2020-10-11 21:07 Christian Grothoff Note Added: 0017009
2020-10-11 21:07 Christian Grothoff Status acknowledged => confirmed
2020-10-11 21:07 Christian Grothoff Target Version => 0.8.1
2020-10-12 13:45 Christian Grothoff Note Added: 0017013
2020-10-12 13:46 Christian Grothoff Assigned To => Christian Grothoff
2020-10-12 13:46 Christian Grothoff Status confirmed => resolved
2020-10-12 13:46 Christian Grothoff Resolution open => fixed
2020-10-12 13:46 Christian Grothoff Fixed in Version => 0.8
2020-10-12 13:46 Christian Grothoff Target Version 0.8.1 => 0.8
2021-08-24 16:23 Christian Grothoff Status resolved => closed