View Issue Details

IDProjectCategoryView StatusLast Update
0005703Talerbank (demonstrator)public2019-05-02 16:03
Reporterng0Assigned Tong0 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0005703: tsc conditional block in web-common produces bad Makefile if condition is false, leading to bank build failure
DescriptionIt is not clear if tsc (and web-common) is a hard dependency for bank, or if some conditional
exception can be applied.

See also #5702
TagsNo tags attached.

Activities

ng0

2019-04-24 13:41

developer   ~0014339

However it could be that I have it wrong, because it's been too long since I installed ntsc (https://www.npmjs.com/package/ntsc).

tsc now reads:

> Use ntypescript https://www.npmjs.com/package/ntypescript as it follows a simple original -> noriginal name transform for require as well as globals tsc & tsserver.

ng0

2019-05-02 16:03

developer   ~0014377

As per Email of 2019-05-02, this is a no-issue.

Issue History

Date Modified Username Field Change
2019-04-24 11:30 ng0 New Issue
2019-04-24 11:30 ng0 Status new => assigned
2019-04-24 11:30 ng0 Assigned To => Marcello Stanisci
2019-04-24 13:41 ng0 Note Added: 0014339
2019-05-02 16:03 ng0 Assigned To Marcello Stanisci => ng0
2019-05-02 16:03 ng0 Status assigned => resolved
2019-05-02 16:03 ng0 Resolution open => fixed
2019-05-02 16:03 ng0 Note Added: 0014377