View Issue Details

IDProjectCategoryView StatusLast Update
0005684libmicrohttpdbuild systempublic2019-08-01 14:38
Reporterng0Assigned ToKarlson2k 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.9.64 
Summary0005684: bootstrap script
DescriptionI fail to see the need for bash arrays in a bootstrap script.

As written on IRC:

I can't even get this to work by just switching into Bash.

It seems to me as if line 2 - 4 (the if) in the bootstrap script either serves a personal purpose
for one of the developers or it is simply too much (which in the first case it would be as well).

I am perfectly able to build MHD when I comment the lines.
TagsNo tags attached.

Activities

Karlson2k

2019-04-10 14:23

developer   ~0014285

Should be fixed in master by 8b8c300312dc33a6c9cef232fb8710cb95723772.
ng0 please check whether it fixed problem for you.

ng0

2019-04-10 21:58

reporter   ~0014287

It does. Thanks!

ng0

2019-05-21 23:55

reporter   ~0014426

Looking at fontforge (https://github.com/fontforge/fontforge/wiki/Building-with-Cygwin) they have a "bootstrap" script which functions under cygwin.

While exploring the build on Windows 10 with cygwin I noticed that the bootstrap script of lmhd does not work under this environment, throwing:

': not a valid identifiert: `bs_srcdir
./bootstrap: line 12: syntax error: unexpected end of file

Karlson2k

2019-05-22 09:33

developer   ~0014427

Last edited: 2019-05-22 09:49

View 4 revisions

Sorry, cannot reproduce.
My steps:
* Install cygwin64, including required packages, like git, gettext-devel, automake, autoconf, gcc-core, binutils etc.
* Clone libmicrohttpd In cygwin command prompt by `git clone https://git.gnunet.org/libmicrohttpd.git cygwin-libmicrohttpd`
* `cd cygwin-libmicrohttpd`
* `./bootstrap`
Works as expected.

Most probably you did not clone under cygwin and tried to reuse repo cloned for MinGW/Windows. This will not work as Git For Windows (by default) change line ending from LF to CRLF.
MinGW's bash (and other tools) specially patched to work with any kind of line ending (either LF or CRLF), but cygwin's bash accept only LF line ending.
You have several options:
* clone special repo only for cygwin under cygwin (cygwin git have correct default settings) - simplest solution.
* change git settings for local clone to use LF line endings.
* manually process files by dos2unix (very inconvenient).

Karlson2k

2019-05-22 09:48

developer   ~0014428

ng0, check following links:
https://stackoverflow.com/questions/14643226/unexpected-end-of-file-in-shell-script
https://stackoverflow.com/questions/50799064/cygwin-bash-unexpected-eof

Please close this ticket if it fix problem for you.

ng0

2019-05-22 11:31

reporter   ~0014430

> Most probably you did not clone under cygwin and tried to reuse repo cloned for MinGW/Windows.

Yes, with the git gui which does not change the line endings. so I assumed it works.
But it didn't.
I'm still new to this cygwin (aside: and the fact that development under windows and cygwin is new to me slows down the task quiet a bit.).
with cygwin git it worked.
thanks!

I can't close this because it is assigned to you and I only have reporter rights in libmicrohttpd.

Issue History

Date Modified Username Field Change
2019-04-07 22:19 ng0 New Issue
2019-04-10 14:23 Karlson2k Note Added: 0014285
2019-04-10 14:24 Karlson2k Assigned To => Karlson2k
2019-04-10 14:24 Karlson2k Status new => assigned
2019-04-10 21:58 ng0 Note Added: 0014287
2019-04-11 11:14 Karlson2k Status assigned => resolved
2019-04-11 11:14 Karlson2k Resolution open => fixed
2019-04-11 11:14 Karlson2k Fixed in Version => 0.9.64
2019-05-21 23:55 ng0 Status resolved => feedback
2019-05-21 23:55 ng0 Resolution fixed => reopened
2019-05-21 23:55 ng0 Note Added: 0014426
2019-05-22 09:33 Karlson2k Note Added: 0014427
2019-05-22 09:40 Karlson2k Note Edited: 0014427 View Revisions
2019-05-22 09:46 Karlson2k Note Edited: 0014427 View Revisions
2019-05-22 09:48 Karlson2k Note Added: 0014428
2019-05-22 09:49 Karlson2k Note Edited: 0014427 View Revisions
2019-05-22 11:31 ng0 Note Added: 0014430
2019-05-22 11:31 ng0 Status feedback => assigned
2019-05-22 18:07 Karlson2k Status assigned => resolved
2019-05-22 18:07 Karlson2k Resolution reopened => fixed
2019-08-01 14:38 Christian Grothoff Status resolved => closed