View Issue Details

IDProjectCategoryView StatusLast Update
0005681GNUnetbuild processpublic2019-05-12 13:29
Reporterng0Assigned Tong0 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.11.4 
Summary0005681: gnunet-qr linking
Descriptionmight need either build-system work or fix on my system. please don't close this with "works for me".

gnunet/bin/gnunet-qr:
    -lzbar.0 => /usr/pkg/lib/libzbar.so.0
    -lSM.7 => /usr/X11R7/lib/libSM.so.7
    -lICE.7 => /usr/X11R7/lib/libICE.so.7
    -lc.12 => /usr/lib/libc.so.12
    -lX11.7 => /usr/X11R7/lib/libX11.so.7
    -lxcb.2 => /usr/X11R7/lib/libxcb.so.2
    -lXau.7 => /usr/X11R7/lib/libXau.so.7
    -lXdmcp.7 => /usr/X11R7/lib/libXdmcp.so.7
    -lXv.2 => /usr/X11R7/lib/libXv.so.2
    -lXext.7 => /usr/X11R7/lib/libXext.so.7
    -ljpeg.9 => /usr/pkg/lib/libjpeg.so.9
    -lpthread.1 => /usr/lib/libpthread.so.1
    -lX11.7 => not found
    -lSM.7 => not found
    -lICE.7 => not found
    -lX11.6 => /usr/pkg/lib/libX11.so.6
    -lxcb.2 => not found
    -lXv.2 => not found
    -lgnunetutil.13 => /usr/pkg/lib/libgnunetutil.so.13
    -lgcrypt.20 => /usr/pkg/lib/libgcrypt.so.20
    -lgpg-error.0 => /usr/pkg/lib/libgpg-error.so.0
    -lintl.1 => /usr/lib/libintl.so.1
    -lltdl.7 => /usr/pkg/lib/libltdl.so.7
    -lidn2.0 => /usr/pkg/lib/libidn2.so.0
    -lunistring.2 => /usr/pkg/lib/libunistring.so.2
    -lz.1 => /usr/lib/libz.so.1
    -lm.0 => /usr/lib/libm.so.0
    -lintl.8 => /usr/pkg/lib/libintl.so.8
TagsNo tags attached.

Activities

Christian Grothoff

2019-04-20 12:00

manager   ~0014308

Very strange, you first list some of the libraries as 'found', and then below the same ones as not found.

In any case, if your platform has 'ldd', you should use it on the various libraries to see which one is badly linked.

This is almost certainly an issue with libzbar or one of its dependencies, or with your linker/loader configuration.

ng0

2019-04-20 12:46

developer   ~0014313

In my experience this is a problem on platforms or systems which do not care about ldd config
or treat it differently than expected (Guix, Nix, pkgsrc on NetBSD, probably more).

So while the individual platforms could catch this, we should do something.

Reading this now again, this is because I need to include the X11R7 installation directory
which probably includes the missing stuff (can't check right now).

Conclusion once I have time to test this on my platform will be to point out that we need to link against a couple more dependencies. Well also I don't have libzbar, so there's that. Let me tinker with the correct solution until I resolve this.

Christian Grothoff

2019-04-20 18:06

manager   ~0014320

This is very certainly not a case where we can do anything. We link against libzbar, and everything else depends on zbar. zbar depends on X11, we shouldn't care (or be aware, or do something special about X11, as long as we don't directly use X11 ourselves). So the moment we did something here, I would have to consider that a bug.

ng0

2019-04-24 13:36

developer   ~0014338

Agreed. If there will be a problem it can be fixed, right now it doesn't look like one (and just my
absence of libzbar being one).

Issue History

Date Modified Username Field Change
2019-04-06 23:30 ng0 New Issue
2019-04-06 23:30 ng0 Status new => assigned
2019-04-06 23:30 ng0 Assigned To => ng0
2019-04-20 12:00 Christian Grothoff Note Added: 0014308
2019-04-20 12:46 ng0 Note Added: 0014313
2019-04-20 18:06 Christian Grothoff Note Added: 0014320
2019-04-24 13:36 ng0 Status assigned => resolved
2019-04-24 13:36 ng0 Resolution open => fixed
2019-04-24 13:36 ng0 Fixed in Version => 0.11.4
2019-04-24 13:36 ng0 Note Added: 0014338
2019-05-12 13:29 Christian Grothoff Status resolved => closed