View Issue Details

IDProjectCategoryView StatusLast Update
0005675GNUnetGNSpublic2019-07-24 20:42
Reporterng0Assigned Toschanzen 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target Version0.11.6Fixed in Version0.11.6 
Summary0005675: gnunet-gns-proxy-setup-ca: support GnuTLS for CA
DescriptionGnuTLS can create CAs.
I have started looking into this for ggpsc.
TagsNo tags attached.

Activities

schanzen

2019-06-21 22:50

developer   ~0014565

Attempted fix in 96f72f827b3bdc01f9a75ec1913a9e15dcb608ea.
Tests (on other OSes) needed. Please provide feedback.

ng0

2019-06-24 19:40

developer   ~0014580

@schanzen, will try and test this on NetBSD this week (26th'ish)

ng0

2019-06-24 19:40

developer   ~0014581

What OS, if any, did you test this on so far?

schanzen

2019-06-26 11:32

developer   ~0014596

Last edited: 2019-06-26 11:33

View 2 revisions

I tested using macOS and debian inside docker.
The problem is not only OS, but also the specific instance of openssl, gnutls(-bin) and the certtool binary.
The combinations are quite large...

schanzen

2019-07-07 21:28

developer   ~0014658

Set to fixed.

Issue History

Date Modified Username Field Change
2019-04-01 19:14 ng0 New Issue
2019-04-01 19:14 ng0 Status new => assigned
2019-04-01 19:14 ng0 Assigned To => ng0
2019-06-05 18:55 Christian Grothoff Target Version 0.12.0 => 0.11.6
2019-06-21 22:50 Christian Grothoff Assigned To ng0 => schanzen
2019-06-21 22:50 schanzen Status assigned => feedback
2019-06-21 22:50 schanzen Note Added: 0014565
2019-06-24 19:40 ng0 Note Added: 0014580
2019-06-24 19:40 ng0 Status feedback => assigned
2019-06-24 19:40 ng0 Note Added: 0014581
2019-06-26 11:32 schanzen Note Added: 0014596
2019-06-26 11:33 schanzen Note Edited: 0014596 View Revisions
2019-07-07 21:28 schanzen Status assigned => resolved
2019-07-07 21:28 schanzen Resolution open => fixed
2019-07-07 21:28 schanzen Note Added: 0014658
2019-07-24 20:41 Christian Grothoff Fixed in Version => 0.11.6
2019-07-24 20:42 Christian Grothoff Status resolved => closed