View Issue Details

IDProjectCategoryView StatusLast Update
0005632GNUnetARM servicepublic2019-07-07 21:25
Reporterng0Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status newResolutionopen 
Platformamd64OSNetBSDOS Version8.99.35
Product Version 
Target VersionFixed in Version 
Summary0005632: unique glitch in gnunet-arm or rc.d? config parsing, environment decides when a valid config file is invalid?
DescriptionSo I have an rc.d init script for gnunet. I'm still testing and improving it.
As the pkgsrc package it's still not ready for prime time usage (the init
script more than the package).

The gnunet init script runs after LOGIN and after NETWORK and DAEMON.
When I have the init script activated to launch automatically, I keep getting
this weird warning from gnunet-arm that it can not parse the config file (will append
a picture from my phone later as I'm not logging the gnunet rc.d so far).
gnunet-arm stops, and the gnunet rc.d service does not start.

Once I'm logged in on tty I can start it.

Upon system shutdown (or reboot, or any reboot action which stops services),
I get the same error.

Now since I'm not sure if it's my rc.d script I am not sure if I have something
here which is unique to the environment rc.d has prior to being logged in
or if it's something we can fix in gnunet and test for.

My rc.d script is located in the files folder here:
https://wip.pkgsrc.org/cgi-bin/gitweb.cgi?p=pkgsrc-wip.git;a=tree;f=gnunet;h=66b7a0c9a5c43b79b4cfbcd1add1e09bcfd23893;hb=HEAD
TagsNo tags attached.

Activities

ng0

2019-03-06 17:48

developer  

20190303_095100.jpg (1,317,016 bytes)

ng0

2019-07-01 13:41

developer   ~0014635

FYI, I haven't tested this on 0.11.5. The problem still applies. Even if you don't know netbsd rc scripts or pkgsrc, it should be possible to debug my mistakes here: https://wip.pkgsrc.org/cgi-bin/gitweb.cgi?p=pkgsrc-wip.git;a=tree;f=gnunet

Issue History

Date Modified Username Field Change
2019-03-06 17:38 ng0 New Issue
2019-03-06 17:48 ng0 File Added: 20190303_095100.jpg
2019-06-05 19:02 Christian Grothoff Target Version => 0.11.6
2019-07-01 13:41 ng0 Note Added: 0014635
2019-07-07 21:25 Christian Grothoff Target Version 0.11.6 =>